summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2012-11-21 12:37:32 -0800
committerSeth M Morton <seth.m.morton@gmail.com>2012-11-21 12:37:32 -0800
commite2ffcfc578d61ebc30bee3c15b35abde1ffb1cbb (patch)
tree13f2104879db6bbc0f9ba67c2518ace6a452eeff /setup.py
parente347b9c79cc687faf92278748af56d4d15a59478 (diff)
downloadnatsort-e2ffcfc578d61ebc30bee3c15b35abde1ffb1cbb.tar.gz
Renamed scripts folder to bin, and added doctests to the natsort.py file
itself
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 14 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index fb726fa..d376690 100644
--- a/setup.py
+++ b/setup.py
@@ -9,20 +9,19 @@ from os.path import join
# Read the natsort.py file for the module version number
import re
VERSIONFILE = 'natsort.py'
+versionsearch = re.compile(r"^__version__ = ['\"]([^'\"]*)['\"]")
with open(VERSIONFILE, "rt") as fl:
- versionstring = fl.readline().strip()
-m = re.search(r"^__version__ = ['\"]([^'\"]*)['\"]", versionstring)
-if m:
- VERSION = m.group(1)
-else:
- s = "Unable to locate version string in {0}"
- raise RuntimeError (s.format(VERSIONFILE))
-
-# A description
-DESCRIPTION = ('Provides routines and a command-line script to sort lists '
- 'naturally')
+ for line in fl:
+ m = versionsearch.search(line)
+ if m:
+ VERSION = m.group(1)
+ break
+ else:
+ s = "Unable to locate version string in {0}"
+ raise RuntimeError (s.format(VERSIONFILE))
# Read in the documentation for the long_description
+DESCRIPTION = 'Sort lists naturally'
try:
with open('README.rst') as fl:
LONG_DESCRIPTION = fl.read()
@@ -37,15 +36,17 @@ setup(name='natsort',
url='https://github.com/SethMMorton/natsort',
license='MIT',
py_modules=['natsort'],
- scripts=[join('scripts', 'natsort')],
+ scripts=[join('bin', 'natsort')],
description=DESCRIPTION,
long_description=LONG_DESCRIPTION,
classifiers=(
- 'Development Status :: 4 - Beta',
+ #'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Intended Audience :: Science/Research',
'Intended Audience :: System Administrators',
'Intended Audience :: Information Technology',
+ 'Operating System :: OS Independent',
'License :: Freeware',
'Natural Language :: English',
'Programming Language :: Python :: 2.6',