summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-11-18 14:34:10 -0800
committerSeth Morton <seth.m.morton@gmail.com>2019-03-03 21:17:49 -0800
commitbac7bc1bb9663adebe0c1768d67c4ed1d1f452fc (patch)
tree85d1dff4c835aeb6a9c1c3846346fecb5b3c4167 /setup.py
parentea0d37ef790b42c424a096e079edd9ea0d5717e3 (diff)
downloadnatsort-bac7bc1bb9663adebe0c1768d67c4ed1d1f452fc.tar.gz
Remove support for Python 2
This commit will prevent pip from installing natsort on any Python version older than 3.4.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 68e06fc..33ef36e 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ setup(
version='6.0.0',
packages=find_packages(),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
+ python_requires=">=3.4",
extras_require={
'fast': ["fastnumbers >= 2.0.0"],
'icu': ["PyICU >= 1.0.0"]