summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2015-06-27 09:59:17 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2015-06-27 09:59:17 -0700
commit88059b35d8544aa013435ad01d073375abbc0811 (patch)
treedc06d4667a8116dfe6489d2ebc6be3746a33c69d /setup.py
parent1e05db22c5b3f54a41585dbea90232dda46a8aea (diff)
downloadnatsort-88059b35d8544aa013435ad01d073375abbc0811.tar.gz
Switched to using find_packages().
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3a4979f..a1950fc 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ import sys
from os.path import join
# Non-std lib imports
-from setuptools import setup
+from setuptools import setup, find_packages
from setuptools.command.test import test as TestCommand
@@ -80,7 +80,7 @@ setup(
url='https://github.com/SethMMorton/natsort',
license='MIT',
install_requires=REQUIRES,
- packages=['natsort', 'natsort.compat'],
+ packages=find_packages(exclude=['test*']),
entry_points={'console_scripts': ['natsort = natsort.__main__:main']},
tests_require=TESTS_REQUIRE,
cmdclass={'test': PyTest},