summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2016-05-02 23:56:08 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2016-05-02 23:56:08 -0700
commit12c27eccadaaf72640736926c68c1539f1b037f7 (patch)
tree478c85001271bc215f11676a611511c4adfd68f4 /setup.py
parenta391cb26600eb7100ef682baa2ba6fbcb5e0ca10 (diff)
downloadnatsort-12c27eccadaaf72640736926c68c1539f1b037f7.tar.gz
3rd attempt to fix Python 2.6 testing bug.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 14 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index cdb52a0..6e9bc70 100644
--- a/setup.py
+++ b/setup.py
@@ -20,22 +20,22 @@ class PyTest(TestCommand):
def run_tests(self):
# import here, cause outside the eggs aren't loaded
+ import pytest
if sys.version[:3] == '2.6':
- flakes_pep8 = []
+ return pytest.main()
else:
- flakes_pep8 = ['--flakes', '--pep8']
- import pytest
- return pytest.main(flakes_pep8 +
- ['--cov', 'natsort',
- '--cov-report', 'term-missing',
- # '-s',
- # '--failed',
- # '-v',
- # 'test_natsort',
- # 'README.rst',
- # 'docs/source/intro.rst',
- # 'docs/source/examples.rst',
- ])
+ return pytest.main(['--cov', 'natsort',
+ '--cov-report', 'term-missing',
+ '--flakes',
+ '--pep8',
+ # '-s',
+ # '--failed',
+ # '-v',
+ # 'test_natsort',
+ # 'README.rst',
+ # 'docs/source/intro.rst',
+ # 'docs/source/examples.rst',
+ ])
# Read the natsort.py file for the module version number