summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSeth M Morton <seth.m.morton@gmail.com>2018-05-12 22:55:16 -0700
committerSeth M Morton <seth.m.morton@gmail.com>2018-05-12 22:55:16 -0700
commit0302a813bf508a7b26220ee3dc7491183becb0c9 (patch)
tree2dc70effde7fd0a820df323ddeb94c9de5f96c1a /setup.py
parent8a5cb95adfe0668dcd0ca625f87db60921207519 (diff)
downloadnatsort-0302a813bf508a7b26220ee3dc7491183becb0c9.tar.gz
Move package to src/natsort.
This makes it more clear during testing that the actual code that is installed is being tested, and not the package in the development area.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 6f70e3e..81bd74a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,7 @@
#! /usr/bin/env python
-from setuptools import setup
-setup()
+from setuptools import setup, find_packages
+setup(
+ packages=find_packages('src'),
+ package_dir={'': 'src'},
+)