summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Morton <seth.m.morton@gmail.com>2023-03-01 21:26:42 -0800
committerSeth Morton <seth.m.morton@gmail.com>2023-03-01 21:26:42 -0800
commit52476290c70a570b643a6fc592fd609065155b72 (patch)
tree0485eef973317dc41fa6d9485b1d84b4c5dc4362
parent1215858e0930dd1ab24c43726725c5e82ea80f87 (diff)
downloadnatsort-52476290c70a570b643a6fc592fd609065155b72.tar.gz
Bump version: 8.3.0 → 8.3.18.3.1
-rw-r--r--CHANGELOG.md4
-rw-r--r--docs/conf.py2
-rw-r--r--natsort/__init__.py2
-rw-r--r--setup.cfg2
-rw-r--r--setup.py2
5 files changed, 8 insertions, 4 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e445b3d..dee5589 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,9 @@
Unreleased
---
+[8.3.1] - 2023-03-01
+---
+
### Fixed
- Broken test on FreeBSD due to a broken `locale.strxfrm`.
**This change has no effect outside fixing tests**
@@ -634,6 +637,7 @@ a pipeline by which to filter
- Sorting algorithm to support floats (including exponentials) and basic version number support
<!---Comparison links-->
+[8.3.1]: https://github.com/SethMMorton/natsort/compare/8.3.0...8.3.1
[8.3.0]: https://github.com/SethMMorton/natsort/compare/8.2.0...8.3.0
[8.2.0]: https://github.com/SethMMorton/natsort/compare/8.1.0...8.2.0
[8.1.0]: https://github.com/SethMMorton/natsort/compare/8.0.2...8.1.0
diff --git a/docs/conf.py b/docs/conf.py
index aef6107..ab9c3ee 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -59,7 +59,7 @@ copyright = "2014, Seth M. Morton"
# built documents.
#
# The full version, including alpha/beta/rc tags.
-release = "8.3.0"
+release = "8.3.1"
# The short X.Y version.
version = ".".join(release.split(".")[0:2])
diff --git a/natsort/__init__.py b/natsort/__init__.py
index d54c6cb..420c2dd 100644
--- a/natsort/__init__.py
+++ b/natsort/__init__.py
@@ -23,7 +23,7 @@ from natsort.natsort import (
from natsort.ns_enum import NSType, ns
from natsort.utils import KeyType, NatsortInType, NatsortOutType, chain_functions
-__version__ = "8.3.0"
+__version__ = "8.3.1"
__all__ = [
"natsort_key",
diff --git a/setup.cfg b/setup.cfg
index 412be68..42ea3b9 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 8.3.0
+current_version = 8.3.1
commit = True
tag = True
tag_name = {new_version}
diff --git a/setup.py b/setup.py
index 9c653fb..ddff592 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@ from setuptools import find_packages, setup
setup(
name="natsort",
- version="8.3.0",
+ version="8.3.1",
packages=find_packages(),
entry_points={"console_scripts": ["natsort = natsort.__main__:main"]},
python_requires=">=3.7",