summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Bienkowski <hexagonrecursion@gmail.com>2021-02-27 01:50:24 +0000
committerGitHub <noreply@github.com>2021-02-27 10:50:24 +0900
commit010de11bedde8d61ced5a382b44a8344d571c305 (patch)
tree541281bf66842346b477229b93d3d456a82408d5
parent44fd5777050c6583791609d3f77e05427bf878a3 (diff)
downloadmsgpack-python-010de11bedde8d61ced5a382b44a8344d571c305.tar.gz
Make pure-python wheels and eggs possible (#467)
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8e88750..751abff 100755
--- a/setup.py
+++ b/setup.py
@@ -88,7 +88,7 @@ else:
macros = [("__LITTLE_ENDIAN__", "1")]
ext_modules = []
-if not PYPY and not PY2:
+if not PYPY and not PY2 and not os.environ.get("MSGPACK_PUREPYTHON"):
ext_modules.append(
Extension(
"msgpack._cmsgpack",