summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Foord <michael@voidspace.org.uk>2012-10-07 18:43:23 +0100
committerMichael Foord <michael@voidspace.org.uk>2012-10-07 18:43:23 +0100
commit1a63f1dc06d1d334e00dbd9e1373d78edb032f2f (patch)
treeaba277ed1f42814fdd93750e9d2291c228ca6f59
parentfcdebb7e690efcfafa062ef1d911ad73555cbcbb (diff)
downloadmock-1a63f1dc06d1d334e00dbd9e1373d78edb032f2f.tar.gz
Final doc updates for 1.0 release
-rw-r--r--README.txt6
-rwxr-xr-xsetup.py1
2 files changed, 4 insertions, 3 deletions
diff --git a/README.txt b/README.txt
index 385db3c..b647c05 100644
--- a/README.txt
+++ b/README.txt
@@ -2,8 +2,8 @@ mock is a library for testing in Python. It allows you to replace parts of
your system under test with mock objects and make assertions about how they
have been used.
-mock is now part of the Python standard library, available as `unittest.mock <
-http://docs.python.org/py3k/library/unittest.mock.html#module-unittest.mock>`_
+mock is now part of the Python standard library, available as `unittest.mock
+<http://docs.python.org/py3k/library/unittest.mock.html#module-unittest.mock>`_
in Python 3.3 onwards.
mock provides a core `MagicMock` class removing the need to create a host of
@@ -18,7 +18,7 @@ with the latest versions of Jython and pypy.
The mock module also provides utility functions / objects to assist with
testing, particularly monkey patching.
-* `PDF documentation for 1.0 beta 1
+* `PDF documentation for 1.0
<http://www.voidspace.org.uk/downloads/mock-1.0.0.pdf>`_
* `mock on google code (repository and issue tracker)
<http://code.google.com/p/mock/>`_
diff --git a/setup.py b/setup.py
index 7c25e8f..917eb1a 100755
--- a/setup.py
+++ b/setup.py
@@ -32,6 +32,7 @@ CLASSIFIERS = [
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3.1',
'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Programming Language :: Python :: Implementation :: Jython',