summaryrefslogtreecommitdiff
path: root/README.py3k
diff options
context:
space:
mode:
Diffstat (limited to 'README.py3k')
-rw-r--r--README.py3k10
1 files changed, 7 insertions, 3 deletions
diff --git a/README.py3k b/README.py3k
index 3e3c8ab..cf51731 100644
--- a/README.py3k
+++ b/README.py3k
@@ -14,7 +14,6 @@ Running as a user with permission to modify the Python distribution,
install Distribute:
python3 distribute_setup.py
-
Installing Mako in Python 3
---------------------------------
@@ -30,15 +29,20 @@ Converting Tests, Examples, Source to Python 3
To convert all files in the source distribution, run
the 2to3 script:
- 2to3 --no-diffs -w lib test examples
+ 2to3 -w mako test
+
+If using 3.1's 2to3 tool, the --no-diffs flag might help
+with unicode issues:
+ 2to3-3.1 -w --no-diffs mako test
+
The above will rewrite all files in-place in Python 3 format.
Running Tests
-------------
To run the unit tests, ensure Distribute is installed as above,
-and also that at least the ./lib/ and ./test/ directories have been converted
+and also that at least the ./mako/ and ./test/ directories have been converted
to Python 3 using the source tool above. A Python 3 version of Nose
can be acquired from Bitbucket using Mercurial: