summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorVinay Sajip <vinay_sajip@yahoo.co.uk>2011-01-25 08:52:11 +0000
committerVinay Sajip <vinay_sajip@yahoo.co.uk>2011-01-25 08:52:11 +0000
commit7562740429164aafce16c3246a629eec66e5c5bc (patch)
tree20bd7d4d7b7caa517d1dd2dcda398f11b9f05ea6 /setup.py
parentd108c4c729ac945d48ca4b9d5ebeb5f790d3d983 (diff)
downloadlogutils-7562740429164aafce16c3246a629eec66e5c5bc.tar.gz
setup.py and documentation tweaks.0.3.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a8a7da6..b0e95a9 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,9 @@ import re
def description():
- readme = open(join(dirname(__file__), 'README.txt')).read()
+ f = open(join(dirname(__file__), 'README.txt'))
+ readme = f.read()
+ f.close()
regexp = r'^logutils\s*[\d.]*\s*\n=======+\s*\n(.*)Requirements '
reqts, = re.findall(regexp, readme, re.DOTALL)
regexp = r'Availability & Documentation\s*\n-----+\s*\n(.*)'
@@ -60,12 +62,13 @@ distutils.core.setup(
long_description = description(),
license='New BSD',
classifiers=[
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production',
'Environment :: Console',
'Intended Audience :: Developers',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ "Programming Language :: Python :: 3",
'Topic :: Software Development',
],
packages=['logutils'],