summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorVinay Sajip <vinay_sajip@yahoo.co.uk>2010-10-28 18:28:38 +0100
committerVinay Sajip <vinay_sajip@yahoo.co.uk>2010-10-28 18:28:38 +0100
commit1af03d40a496fa137e4cd159e8858ee7b447aafe (patch)
treeed87aae17cd3dd67898bae9a801a1c97275239ac /doc
parente4d7ee3231a2544d18c0caece889026a1b0d11e0 (diff)
downloadlogutils-1af03d40a496fa137e4cd159e8858ee7b447aafe.tar.gz
Changes for 0.20.2
Diffstat (limited to 'doc')
-rw-r--r--doc/Makefile42
-rw-r--r--doc/conf.py68
-rw-r--r--doc/index.rst29
3 files changed, 83 insertions, 56 deletions
diff --git a/doc/Makefile b/doc/Makefile
index ef87680..dbc6dec 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -9,7 +9,7 @@ PAPER =
# Internal variables.
PAPEROPT_a4 = -D latex_paper_size=a4
PAPEROPT_letter = -D latex_paper_size=letter
-ALLSPHINXOPTS = -d .build/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+ALLSPHINXOPTS = -d _build/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
.PHONY: help clean html web pickle htmlhelp latex changes linkcheck
@@ -24,52 +24,52 @@ help:
@echo " linkcheck to check all external links for integrity"
clean:
- -rm -rf .build/*
+ -rm -rf _build/*
html:
- mkdir -p .build/html .build/doctrees
- $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) .build/html
+ mkdir -p _build/html _build/doctrees
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) _build/html
@echo
- @echo "Build finished. The HTML pages are in .build/html."
+ @echo "Build finished. The HTML pages are in _build/html."
pickle:
- mkdir -p .build/pickle .build/doctrees
- $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) .build/pickle
+ mkdir -p _build/pickle _build/doctrees
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) _build/pickle
@echo
@echo "Build finished; now you can process the pickle files."
web: pickle
json:
- mkdir -p .build/json .build/doctrees
- $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) .build/json
+ mkdir -p _build/json _build/doctrees
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) _build/json
@echo
@echo "Build finished; now you can process the JSON files."
htmlhelp:
- mkdir -p .build/htmlhelp .build/doctrees
- $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) .build/htmlhelp
+ mkdir -p _build/htmlhelp _build/doctrees
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) _build/htmlhelp
@echo
@echo "Build finished; now you can run HTML Help Workshop with the" \
- ".hhp project file in .build/htmlhelp."
+ ".hhp project file in _build/htmlhelp."
latex:
- mkdir -p .build/latex .build/doctrees
- $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) .build/latex
+ mkdir -p _build/latex _build/doctrees
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) _build/latex
@echo
- @echo "Build finished; the LaTeX files are in .build/latex."
+ @echo "Build finished; the LaTeX files are in _build/latex."
@echo "Run \`make all-pdf' or \`make all-ps' in that directory to" \
"run these through (pdf)latex."
changes:
- mkdir -p .build/changes .build/doctrees
- $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) .build/changes
+ mkdir -p _build/changes _build/doctrees
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) _build/changes
@echo
- @echo "The overview file is in .build/changes."
+ @echo "The overview file is in _build/changes."
linkcheck:
- mkdir -p .build/linkcheck .build/doctrees
- $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) .build/linkcheck
+ mkdir -p _build/linkcheck _build/doctrees
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) _build/linkcheck
@echo
@echo "Link check complete; look for any errors in the above output " \
- "or in .build/linkcheck/output.txt."
+ "or in _build/linkcheck/output.txt."
diff --git a/doc/conf.py b/doc/conf.py
index eedf48d..a1af384 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -1,10 +1,13 @@
# -*- coding: utf-8 -*-
#
-# argparse documentation build configuration file, created by
-# sphinx-quickstart on Thu Mar 26 10:47:44 2009.
+# Logutils documentation build configuration file, created by
+# sphinx-quickstart on Fri Oct 1 15:54:52 2010.
#
# This file is execfile()d with the current directory set to its containing dir.
#
+# The contents of this file are pickled, so don't put values in the namespace
+# that aren't pickleable (module imports are okay, they're removed automatically).
+#
# Note that not all possible configuration values are present in this
# autogenerated file.
#
@@ -13,16 +16,17 @@
import sys, os
-# If extensions (or modules to document with autodoc) are in another directory,
+# If your extensions (or modules documented by autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
-#sys.path.append(os.path.abspath('.'))
+sys.path.append(os.path.abspath('..'))
-# -- General configuration -----------------------------------------------------
+# General configuration
+# ---------------------
# Add any Sphinx extension module names here, as strings. They can be extensions
# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.doctest', 'sphinx.ext.coverage']
+extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx']
# Add any paths that contain templates here, relative to this directory.
templates_path = ['_templates']
@@ -37,7 +41,7 @@ source_suffix = '.rst'
master_doc = 'index'
# General information about the project.
-project = u'logutils'
+project = u'Logutils'
copyright = u'2010, Vinay Sajip'
# The version info for the project you're documenting, acts as replacement for
@@ -45,9 +49,9 @@ copyright = u'2010, Vinay Sajip'
# built documents.
#
# The short X.Y version.
-version = '0.1'
+version = '0.2'
# The full version, including alpha/beta/rc tags.
-release = '0.1'
+release = '0.2'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
@@ -64,7 +68,7 @@ release = '0.1'
# List of directories, relative to source directory, that shouldn't be searched
# for source files.
-exclude_trees = []
+exclude_trees = ['_build']
# The reST default role (used for this markup: `text`) to use for all documents.
#default_role = None
@@ -83,23 +87,14 @@ exclude_trees = []
# The name of the Pygments (syntax highlighting) style to use.
pygments_style = 'sphinx'
-# A list of ignored prefixes for module index sorting.
-#modindex_common_prefix = []
-
-
-# -- Options for HTML output ---------------------------------------------------
-# The theme to use for HTML and HTML Help pages. Major themes that come with
-# Sphinx are currently 'default' and 'sphinxdoc'.
-html_theme = 'default'
+# Options for HTML output
+# -----------------------
-# Theme options are theme-specific and customize the look and feel of a theme
-# further. For a list of options available for each theme, see the
-# documentation.
-#html_theme_options = {}
-
-# Add any paths that contain custom themes here, relative to this directory.
-#html_theme_path = []
+# The style sheet to use for HTML and HTML Help pages. A file of that name
+# must exist either in Sphinx' static/ path, or in one of the custom paths
+# given in html_static_path.
+html_style = 'default.css'
# The name for this set of Sphinx documents. If None, it defaults to
# "<project> v<release> documentation".
@@ -146,8 +141,8 @@ html_static_path = ['_static']
# If true, the index is split into individual pages for each letter.
#html_split_index = False
-# If true, links to the reST sources are added to the pages.
-#html_show_sourcelink = True
+# If true, the reST sources are included in the HTML build as _sources/<name>.
+#html_copy_source = True
# If true, an OpenSearch description file will be output, and all pages will
# contain a <link> tag referring to it. The value of this option must be the
@@ -158,10 +153,11 @@ html_static_path = ['_static']
#html_file_suffix = ''
# Output file base name for HTML help builder.
-htmlhelp_basename = 'logutils'
+htmlhelp_basename = 'Logutilsdoc'
-# -- Options for LaTeX output --------------------------------------------------
+# Options for LaTeX output
+# ------------------------
# The paper size ('letter' or 'a4').
#latex_paper_size = 'letter'
@@ -170,10 +166,10 @@ htmlhelp_basename = 'logutils'
#latex_font_size = '10pt'
# Grouping the document tree into LaTeX files. List of tuples
-# (source start file, target name, title, author, documentclass [howto/manual]).
+# (source start file, target name, title, author, document class [howto/manual]).
latex_documents = [
- ('index', 'logutils.tex', u'logutils Documentation',
- u'Vinay Sajip', 'manual'),
+ ('index', 'Logutils.tex', ur'Logutils Documentation',
+ ur'Vinay Sajip', 'manual'),
]
# The name of an image file (relative to this directory) to place at the top of
@@ -193,6 +189,8 @@ latex_documents = [
# If false, no module index is generated.
#latex_use_modindex = True
-# Python code that is treated like it were put in a testsetup directive for
-# every file that is tested, and for every group.
-doctest_global_setup = "import logutils"
+
+# Example configuration for intersphinx: refer to the Python standard library.
+intersphinx_mapping = {
+ 'http://docs.python.org/dev': None,
+}
diff --git a/doc/index.rst b/doc/index.rst
index e69de29..2d971ee 100644
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -0,0 +1,29 @@
+.. Logutils documentation master file, created by sphinx-quickstart on Fri Oct 1 15:54:52 2010.
+ You can adapt this file completely to your liking, but it should at least
+ contain the root `toctree` directive.
+
+Logutils documentation
+======================
+
+.. automodule:: logutils
+
+There are a number of subcomponents to this package, relating to particular
+tasks you may want to perform:
+
+.. toctree::
+ :maxdepth: 2
+
+ libraries
+ queue
+ testing
+ dictconfig
+ adapter
+ http
+
+Indices and tables
+==================
+
+* :ref:`genindex`
+* :ref:`modindex`
+* :ref:`search`
+