summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8f27b3b..9ac5255 100644
--- a/setup.py
+++ b/setup.py
@@ -143,7 +143,7 @@ class MyBuildPy(build_py):
# brackets are NOT optional here for py3k compat
print('running 2to3 on', dest)
# Needs `shell=True` to run on Windows.
- check_call(['2to3', '-wn', dest], shell=True)
+ check_call(['2to3', '-wn', dest], shell=sys.platform=='win32')
def install(**kwargs):