summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSylvain <syt@logilab.fr>2006-11-10 12:56:19 +0100
committerSylvain <syt@logilab.fr>2006-11-10 12:56:19 +0100
commit44d20837bc57e982468e9ed3cfd16e14bd653405 (patch)
tree7f0fe5b80e8f799feeb54148fced3f0b1980554d /setup.py
parent81fd4b08bd05f2553752e297d4768a76033d1b24 (diff)
downloadlogilab-common-44d20837bc57e982468e9ed3cfd16e14bd653405.tar.gz
generalize STD_BLACKLIST usage
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 8a1d555..54a0def 100644
--- a/setup.py
+++ b/setup.py
@@ -17,10 +17,6 @@
# 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
""" Generic Setup script, takes package info from __pkginfo__.py file """
-from __future__ import nested_scopes
-
-__revision__ = '$Id: setup.py,v 1.24 2006-04-10 15:12:53 syt Exp $'
-
import os
import sys
import shutil
@@ -58,6 +54,7 @@ try:
except ImportError:
ext_modules = None
+from __init__ import STD_BLACKLIST, IGNORED_EXTENSIONS
BASE_BLACKLIST = ('CVS', 'debian', 'dist', 'build', '__buildlog', '.svn')
IGNORED_EXTENSIONS = ('.pyc', '.pyo', '.elc')
@@ -92,7 +89,7 @@ def get_packages(directory, prefix):
return result
def export(from_dir, to_dir,
- blacklist=BASE_BLACKLIST,
+ blacklist=STD_BLACKLIST,
ignore_ext=IGNORED_EXTENSIONS):
"""make a mirror of from_dir in to_dir, omitting directories and files
listed in the black list