summaryrefslogtreecommitdiff
path: root/__pkginfo__.py
diff options
context:
space:
mode:
authorJulien Jehannet <julien.jehannet@logilab.fr>2010-05-21 11:38:22 +0200
committerJulien Jehannet <julien.jehannet@logilab.fr>2010-05-21 11:38:22 +0200
commit4ca8d7b3bd503943207a71772aa600385754cc9c (patch)
tree343c647f19336c93b89453bf16a3d11fe1951338 /__pkginfo__.py
parent041a61675434ce261afb06d926df5b96478e2bb9 (diff)
downloadlogilab-common-4ca8d7b3bd503943207a71772aa600385754cc9c.tar.gz
pkginfo: update setup.py from new policy
Diffstat (limited to '__pkginfo__.py')
-rw-r--r--__pkginfo__.py27
1 files changed, 5 insertions, 22 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
index b6f60f7..bd9c7da 100644
--- a/__pkginfo__.py
+++ b/__pkginfo__.py
@@ -20,34 +20,17 @@ __docformat__ = "restructuredtext en"
distname = 'logilab-common'
modname = 'common'
+
numversion = (0, 50, 1)
version = '.'.join([str(num) for num in numversion])
-copyright = '2003-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.'
+
+copyright = 'Copyright (c) 2003-2010 LOGILAB S.A. (Paris, FRANCE), all rights reserved.'
license = 'LGPL' # 2.1 or later
author = "Logilab"
-author_email = "devel@logilab.fr"
-
-short_desc = "useful miscellaneous modules used by Logilab projects"
-
-long_desc = """logilab-common is a collection of low-level Python packages and \
-modules,
- designed to ease:
- * handling command line options and configuration files
- * writing interactive command line tools
- * manipulation files and character strings
- * interfacing to OmniORB
- * generating SQL queries
- * running unit tests
- * manipulating tree structures
- * accessing RDBMS (currently postgreSQL, mysql and sqlite)
- * generating text and HTML reports
- * logging
- * parsing XML processing instructions
- * more...
-"""
-
+author_email = "contact@logilab.fr"
+description = "collection of low-level Python packages and modules used by Logilab projects"
web = "http://www.logilab.org/project/%s" % distname
ftp = "ftp://ftp.logilab.org/pub/%s" % modname
mailinglist = "mailto://python-projects@lists.logilab.org"