summaryrefslogtreecommitdiff
path: root/__pkginfo__.py
diff options
context:
space:
mode:
authorRémi Cardona <remi.cardona@logilab.fr>2015-05-28 14:39:25 +0200
committerRémi Cardona <remi.cardona@logilab.fr>2015-05-28 14:39:25 +0200
commit06becb75c2f4fc1a4b821bbfb6cfdf711d6bba33 (patch)
treed815d1df36f2ffbf38b97d60dbe45a2731636764 /__pkginfo__.py
parent30655afccc28f7a7f98af812d95a2ca98be64f76 (diff)
downloadlogilab-common-06becb75c2f4fc1a4b821bbfb6cfdf711d6bba33.tar.gz
[pkg] pure setuptools setup.py (closes #294479)
- stop installing __pkginfo__ (move it back to root dir) - adapt all packaging to use setuptools
Diffstat (limited to '__pkginfo__.py')
-rw-r--r--__pkginfo__.py57
1 files changed, 57 insertions, 0 deletions
diff --git a/__pkginfo__.py b/__pkginfo__.py
new file mode 100644
index 0000000..7ebce74
--- /dev/null
+++ b/__pkginfo__.py
@@ -0,0 +1,57 @@
+# copyright 2003-2014 LOGILAB S.A. (Paris, FRANCE), all rights reserved.
+# contact http://www.logilab.fr/ -- mailto:contact@logilab.fr
+#
+# This file is part of logilab-common.
+#
+# logilab-common is free software: you can redistribute it and/or modify it under
+# the terms of the GNU Lesser General Public License as published by the Free
+# Software Foundation, either version 2.1 of the License, or (at your option) any
+# later version.
+#
+# logilab-common is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for more
+# details.
+#
+# You should have received a copy of the GNU Lesser General Public License along
+# with logilab-common. If not, see <http://www.gnu.org/licenses/>.
+"""logilab.common packaging information"""
+__docformat__ = "restructuredtext en"
+import sys
+import os
+
+distname = 'logilab-common'
+modname = 'common'
+subpackage_of = 'logilab'
+subpackage_master = True
+
+numversion = (0, 63, 2)
+version = '.'.join([str(num) for num in numversion])
+
+license = 'LGPL' # 2.1 or later
+description = "collection of low-level Python packages and modules used by Logilab projects"
+web = "http://www.logilab.org/project/%s" % distname
+mailinglist = "mailto://python-projects@lists.logilab.org"
+author = "Logilab"
+author_email = "contact@logilab.fr"
+
+
+from os.path import join
+scripts = [join('bin', 'pytest')]
+include_dirs = [join('test', 'data')]
+
+install_requires = [
+ 'six >= 1.4.0',
+ ]
+tests_require = ['pytz']
+
+if sys.version_info < (2, 7):
+ install_requires.append('unittest2 >= 0.5.1')
+if os.name == 'nt':
+ install_requires.append('colorama')
+
+classifiers = ["Topic :: Utilities",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ ]