summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Grainger <tom@yplanapp.com>2015-10-16 00:51:33 +0100
committerThomas Grainger <tom@yplanapp.com>2015-10-22 11:49:41 +0100
commitd5afa7891925eb790dfc7d670287018e1e5e9e4c (patch)
treeca18717ea151b63f483962d3c1bb4a04caea75e9
parent4a7a20d91c44d2be6396be5fc64d27b0b5afa4e2 (diff)
downloadlockfile-d5afa7891925eb790dfc7d670287018e1e5e9e4c.tar.gz
PBR setup requirement only
Change-Id: Ifcf7227bc14e8d74e0cd8423c127464b8fd8064a Closes-Bug: #1506679
-rw-r--r--requirements.txt5
-rw-r--r--setup.py3
-rw-r--r--test-requirements.txt5
-rw-r--r--tox.ini1
4 files changed, 5 insertions, 9 deletions
diff --git a/requirements.txt b/requirements.txt
deleted file mode 100644
index c81bd8e..0000000
--- a/requirements.txt
+++ /dev/null
@@ -1,5 +0,0 @@
-# The order of packages is significant, because pip processes them in the order
-# of appearance. Changing the order has an impact on the overall integration
-# process, which may cause wedges in the gate later.
-
-pbr>=0.6,!=0.7,<1.0
diff --git a/setup.py b/setup.py
index 7363757..782bb21 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -26,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
- setup_requires=['pbr'],
+ setup_requires=['pbr>=1.8'],
pbr=True)
diff --git a/test-requirements.txt b/test-requirements.txt
index d0e5cff..446a41f 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,2 +1,5 @@
+# The order of packages is significant, because pip processes them in the order
+# of appearance. Changing the order has an impact on the overall integration
+# process, which may cause wedges in the gate later.
nose
-sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
diff --git a/tox.ini b/tox.ini
index df64d02..b0a868a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,6 @@ envlist = py26,py27,py32,py33,py34
[testenv]
deps = -r{toxinidir}/test-requirements.txt
- -r{toxinidir}/requirements.txt
commands=nosetests
[testenv:venv]