summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8228d69..0b94c10 100644
--- a/setup.py
+++ b/setup.py
@@ -195,6 +195,13 @@ if 'bdist_egg' in sys.argv and 'build' not in sys.argv:
sys.argv[:_index] + ['build', 'bdist_egg'] + sys.argv[_index + 1:]
)
+# 'test doesn't always call build for some reason
+if 'test' in sys.argv and 'build' not in sys.argv:
+ _index = sys.argv.index('test')
+ sys.argv[:] = (
+ sys.argv[:_index] + ['build', 'test'] + sys.argv[_index + 1:]
+ )
+
setup(
name='librabbitmq',
version=version,