summaryrefslogtreecommitdiff
path: root/build-manylinux1-wheels.sh
diff options
context:
space:
mode:
Diffstat (limited to 'build-manylinux1-wheels.sh')
-rwxr-xr-xbuild-manylinux1-wheels.sh13
1 files changed, 9 insertions, 4 deletions
diff --git a/build-manylinux1-wheels.sh b/build-manylinux1-wheels.sh
index c0a3901..664075c 100755
--- a/build-manylinux1-wheels.sh
+++ b/build-manylinux1-wheels.sh
@@ -2,13 +2,12 @@
# Script modified from https://github.com/pypa/python-manylinux-demo
set -e -x
-# Install a system package required by our library
-yum install -y librabbitmq-devel make librabbitmq python-devel gcc automake
-
+# Install system packages required by our library
+yum install -y cmake openssl-devel gcc automake
# Compile wheels
for PYBIN in /opt/python/*/bin; do
- #${PYBIN}/pip install -r /workspace/dev-requirements.txt
+ (cd /workspace && ${PYBIN}/python setup.py install)
${PYBIN}/pip wheel /workspace/ -w wheelhouse/
done
@@ -20,6 +19,12 @@ done
# Install packages and test
for PYBIN in /opt/python/*/bin/; do
+ # vine 5.0.0a1 breaks python2
+ # https://github.com/celery/vine/issues/34
+ if [[ "$PYBIN" == *"python/cp2"* ]]; then
+ ${PYBIN}/pip install -f "vine==1.3.0"
+ fi
+
${PYBIN}/pip install librabbitmq -f /workspace/wheelhouse
${PYBIN}/python -c "import librabbitmq"
#(cd $HOME; ${PYBIN}/nosetests pymanylinuxdemo)