summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 537d65c..659888a 100644
--- a/Makefile
+++ b/Makefile
@@ -80,11 +80,12 @@ flakeplusdiag:
flakes: flakediag flakeplusdiag
-test:
- nosetests -xv librabbitmq.tests
+test: build
+ python setup.py test
-cov:
- nosetests -xv librabbitmq.tests --with-coverage --cover-html --cover-branch
+cov: build
+ coverage run --source=librabbitmq setup.py test
+ coverage report
removepyc:
-find . -type f -a \( -name "*.pyc" -o -name "*$$py.class" \) | xargs rm