summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatus Valo <matusvalo@gmail.com>2018-01-21 14:40:49 -0800
committerMatus Valo <matusvalo@gmail.com>2018-01-21 14:48:47 -0800
commit02d5e0a7aeb38fc60b82d40dc1bd6e5d396a4a32 (patch)
tree068a813a5d8200ad3054738f2c026ebab91a0467 /setup.py
parentad09baa74c3a921428426ccdf525b7c4c64bbc0b (diff)
downloadlibrabbitmq-02d5e0a7aeb38fc60b82d40dc1bd6e5d396a4a32.tar.gz
Unittests can be run directly without installation of library
Unittests are now migrated from nose to python standard unittests runner and Makefile calls tests directly from setup.py. This enables running tests without installation in system.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0b94c10..ec00de9 100644
--- a/setup.py
+++ b/setup.py
@@ -211,7 +211,7 @@ setup(
license='MPL',
description='AMQP Client using the rabbitmq-c library.',
long_description=long_description,
- test_suite='nose.collector',
+ test_suite="tests",
zip_safe=False,
packages=packages,
cmdclass=cmdclass,