summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorrmihael <rmihael@gmail.com>2014-12-15 17:44:38 +0200
committerAsk Solem <ask@celeryproject.org>2015-10-30 12:11:51 -0700
commiteb22f17f07d610daac60a0884d0485f9f8c7f0f8 (patch)
treebf3bca69ef0fccaa3546a9a56d5d12f8f0430fb4
parent6f1e0132efeeb1b0a8a2895973d2db6f1a7b2b84 (diff)
downloadlibrabbitmq-eb22f17f07d610daac60a0884d0485f9f8c7f0f8.tar.gz
Update setup.py to fix buildout-related problems
There're some issues related to Buildout having troubles installing librabbitmq: https://github.com/celery/librabbitmq/issues/61, https://github.com/celery/librabbitmq/issues/58 It seems that this simple change fixes it. Not the prettiest solution, but it works.
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6399c56..58118de 100644
--- a/setup.py
+++ b/setup.py
@@ -208,7 +208,13 @@ if 'install' in sys.argv and 'build' not in sys.argv:
sys.argv[:] = (
sys.argv[:_index] + ['build', 'install'] + sys.argv[_index + 1:]
)
-
+
+# 'bdist_egg doesn't always call build for some reason
+if 'bdist_egg' in sys.argv and 'build' not in sys.argv:
+ _index = sys.argv.index('bdist_egg')
+ sys.argv[:] = (
+ sys.argv[:_index] + ['build', 'bdist_egg'] + sys.argv[_index + 1:]
+ )
setup(
name='librabbitmq',