summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOmer Katz <omer.drow@gmail.com>2018-03-07 19:05:50 +0200
committerGitHub <noreply@github.com>2018-03-07 19:05:50 +0200
commitc78417045f9709adb4917c8bd369d044731afdba (patch)
tree40dc0dcd706ab145e1b4dc454617ca84caa701d2
parent3bae8df1d95b47bd10f3232c8f13d3c07069619b (diff)
parentff0ea57bdc8f7d929b65d15a295eb858ccadf82e (diff)
downloadlibrabbitmq-c78417045f9709adb4917c8bd369d044731afdba.tar.gz
Merge pull request #114 from timkpaine/master
lets you build for python 3 by doing make PYTHON=python3
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 659888a..bb073c0 100644
--- a/Makefile
+++ b/Makefile
@@ -29,16 +29,16 @@ clean-build:
-rm -rf build
build: clean-build dist
- python setup.py build
+ $(PYTHON) setup.py build
install: build
- python setup.py install
+ $(PYTHON) setup.py install
develop: build
- python setup.py develop
+ $(PYTHON) setup.py develop
pyclean:
- -python setup.py clean
+ -$(PYTHON) setup.py clean
-rm -rf build
-rm -f _librabbitmq.so
@@ -60,8 +60,8 @@ manylinux1: dist
docker run --rm -v `pwd`:/workspace:z quay.io/pypa/manylinux1_x86_64 /workspace/build-manylinux1-wheels.sh
rebuild:
- python setup.py build
- python setup.py install
+ $(PYTHON) setup.py build
+ $(PYTHON) setup.py install
# Distro tools
@@ -81,7 +81,7 @@ flakeplusdiag:
flakes: flakediag flakeplusdiag
test: build
- python setup.py test
+ $(PYTHON) setup.py test
cov: build
coverage run --source=librabbitmq setup.py test