summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saifuddin Auvi <auvipy@users.noreply.github.com>2016-09-03 10:53:06 +0600
committerGitHub <noreply@github.com>2016-09-03 10:53:06 +0600
commit91100605c60bab96c67330352f984a9bdf72d45c (patch)
tree8689b1200dad68b39da62f99308ad950952b17fe
parent77b232150ee6ab55c8acae9d9d3c5b8d33abf581 (diff)
parent10bf3a595377c34d8e909dce286cf688428eaeb5 (diff)
downloadlibrabbitmq-91100605c60bab96c67330352f984a9bdf72d45c.tar.gz
Merge pull request #87 from amitsaha/manylinux1
Manylinux1 wheels
-rw-r--r--Makefile2
-rwxr-xr-xbuild-manylinux1-wheels.sh26
-rw-r--r--manylinux12
-rw-r--r--wheelhouse/librabbitmq-1.6.1-cp26-cp26m-manylinux1_x86_64.whlbin0 -> 210947 bytes
-rw-r--r--wheelhouse/librabbitmq-1.6.1-cp26-cp26mu-manylinux1_x86_64.whlbin0 -> 210947 bytes
-rw-r--r--wheelhouse/librabbitmq-1.6.1-cp27-cp27m-manylinux1_x86_64.whlbin0 -> 211020 bytes
-rw-r--r--wheelhouse/librabbitmq-1.6.1-cp27-cp27mu-manylinux1_x86_64.whlbin0 -> 211020 bytes
7 files changed, 30 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 1954145..8147268 100644
--- a/Makefile
+++ b/Makefile
@@ -63,6 +63,8 @@ $(RABBIT_TARGET):
dist: rabbitmq-c $(RABBIT_TARGET)
+manylinux1: dist
+ docker run --rm -v `pwd`:/workspace:z quay.io/pypa/manylinux1_x86_64 /workspace/build-manylinux1-wheels.sh
rebuild:
python setup.py build
diff --git a/build-manylinux1-wheels.sh b/build-manylinux1-wheels.sh
new file mode 100755
index 0000000..8a8e34b
--- /dev/null
+++ b/build-manylinux1-wheels.sh
@@ -0,0 +1,26 @@
+#!/bin/bash
+# Script modified from https://github.com/pypa/python-manylinux-demo
+set -e -x
+
+# Install a system package required by our library
+yum install -y librabbmitmq-devel make librabbitmq python-dev gcc automake
+
+
+# Compile wheels
+for PYBIN in /opt/python/*/bin; do
+ #${PYBIN}/pip install -r /workspace/dev-requirements.txt
+ ${PYBIN}/pip wheel /workspace/ -w wheelhouse/
+done
+
+# Bundle external shared libraries into the wheels
+#ls wheelhouse/*
+for whl in wheelhouse/*linux*.whl; do
+ auditwheel repair $whl -w /workspace/wheelhouse/
+done
+
+# Install packages and test
+for PYBIN in /opt/python/*/bin/; do
+ ${PYBIN}/pip install librabbitmq -f /workspace/wheelhouse
+ ${PYBIN}/python -c "import librabbitmq"
+ #(cd $HOME; ${PYBIN}/nosetests pymanylinuxdemo)
+done
diff --git a/manylinux1 b/manylinux1
new file mode 100644
index 0000000..9619d36
--- /dev/null
+++ b/manylinux1
@@ -0,0 +1,2 @@
+docker run --rm -v `pwd`:/workspace:z quay.io/pypa/manylinux1_x86_64 /workspace/build-manylinux1-wheels.sh
+
diff --git a/wheelhouse/librabbitmq-1.6.1-cp26-cp26m-manylinux1_x86_64.whl b/wheelhouse/librabbitmq-1.6.1-cp26-cp26m-manylinux1_x86_64.whl
new file mode 100644
index 0000000..4d7a957
--- /dev/null
+++ b/wheelhouse/librabbitmq-1.6.1-cp26-cp26m-manylinux1_x86_64.whl
Binary files differ
diff --git a/wheelhouse/librabbitmq-1.6.1-cp26-cp26mu-manylinux1_x86_64.whl b/wheelhouse/librabbitmq-1.6.1-cp26-cp26mu-manylinux1_x86_64.whl
new file mode 100644
index 0000000..a98f1d0
--- /dev/null
+++ b/wheelhouse/librabbitmq-1.6.1-cp26-cp26mu-manylinux1_x86_64.whl
Binary files differ
diff --git a/wheelhouse/librabbitmq-1.6.1-cp27-cp27m-manylinux1_x86_64.whl b/wheelhouse/librabbitmq-1.6.1-cp27-cp27m-manylinux1_x86_64.whl
new file mode 100644
index 0000000..fb26682
--- /dev/null
+++ b/wheelhouse/librabbitmq-1.6.1-cp27-cp27m-manylinux1_x86_64.whl
Binary files differ
diff --git a/wheelhouse/librabbitmq-1.6.1-cp27-cp27mu-manylinux1_x86_64.whl b/wheelhouse/librabbitmq-1.6.1-cp27-cp27mu-manylinux1_x86_64.whl
new file mode 100644
index 0000000..248339d
--- /dev/null
+++ b/wheelhouse/librabbitmq-1.6.1-cp27-cp27mu-manylinux1_x86_64.whl
Binary files differ