summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.rst36
-rw-r--r--docs/includes/introduction.txt12
-rw-r--r--kombu/clocks.py4
-rw-r--r--kombu/compat.py2
-rw-r--r--kombu/serialization.py2
-rw-r--r--kombu/transport/SQS.py4
-rw-r--r--kombu/transport/librabbitmq.py2
-rw-r--r--kombu/transport/mongodb.py2
-rw-r--r--kombu/transport/qpid.py6
-rw-r--r--kombu/utils/limits.py4
-rw-r--r--setup.py2
11 files changed, 38 insertions, 38 deletions
diff --git a/README.rst b/README.rst
index b202694c..05af2050 100644
--- a/README.rst
+++ b/README.rst
@@ -62,20 +62,20 @@ Features
For an introduction to AMQP you should read the article `Rabbits and warrens`_,
and the `Wikipedia article about AMQP`_.
-.. _`RabbitMQ`: http://www.rabbitmq.com/
-.. _`AMQP`: http://amqp.org
-.. _`py-amqp`: http://pypi.python.org/pypi/amqp/
-.. _`qpid-python`: http://pypi.python.org/pypi/qpid-python/
-.. _`Redis`: http://code.google.com/p/redis/
-.. _`Amazon SQS`: http://aws.amazon.com/sqs/
+.. _`RabbitMQ`: https://www.rabbitmq.com/
+.. _`AMQP`: https://amqp.org
+.. _`py-amqp`: https://pypi.python.org/pypi/amqp/
+.. _`qpid-python`: https://pypi.python.org/pypi/qpid-python/
+.. _`Redis`: https://redis.io
+.. _`Amazon SQS`: https://aws.amazon.com/sqs/
.. _`Zookeeper`: https://zookeeper.apache.org/
.. _`Rabbits and warrens`: http://blogs.digitar.com/jjww/2009/01/rabbits-and-warrens/
-.. _`amqplib`: http://barryp.org/software/py-amqplib/
-.. _`Wikipedia article about AMQP`: http://en.wikipedia.org/wiki/AMQP
-.. _`carrot`: http://pypi.python.org/pypi/carrot/
-.. _`librabbitmq`: http://pypi.python.org/pypi/librabbitmq
-.. _`Pyro`: http://pythonhosting.org/Pyro
-.. _`SoftLayer MQ`: http://www.softlayer.com/services/additional/message-queue
+.. _`amqplib`: https://barryp.org/software/py-amqplib/
+.. _`Wikipedia article about AMQP`: https://en.wikipedia.org/wiki/AMQP
+.. _`carrot`: https://pypi.python.org/pypi/carrot/
+.. _`librabbitmq`: https://pypi.python.org/pypi/librabbitmq
+.. _`Pyro`: https://pythonhosting.org/Pyro4
+.. _`SoftLayer MQ`: https://sldn.softlayer.com/reference/messagequeueapi
.. _transport-comparison:
@@ -310,18 +310,18 @@ Mailing list
Join the `carrot-users`_ mailing list.
-.. _`carrot-users`: http://groups.google.com/group/carrot-users/
+.. _`carrot-users`: https://groups.google.com/group/carrot-users/
Bug tracker
===========
If you have any suggestions, bug reports or annoyances please report them
-to our issue tracker at http://github.com/celery/kombu/issues/
+to our issue tracker at https://github.com/celery/kombu/issues/
Contributing
============
-Development of `Kombu` happens at Github: http://github.com/celery/kombu
+Development of `Kombu` happens at Github: https://github.com/celery/kombu
You are highly encouraged to participate in the development. If you don't
like Github (for some reason) you're welcome to send regular patches.
@@ -346,14 +346,14 @@ file in the top distribution directory for the full license text.
.. |wheel| image:: https://img.shields.io/pypi/wheel/kombu.svg
:alt: Kombu can be installed via wheel
- :target: http://pypi.python.org/pypi/kombu/
+ :target: https://pypi.python.org/pypi/kombu/
.. |pyversion| image:: https://img.shields.io/pypi/pyversions/kombu.svg
:alt: Supported Python versions.
- :target: http://pypi.python.org/pypi/kombu/
+ :target: https://pypi.python.org/pypi/kombu/
.. |pyimp| image:: https://img.shields.io/pypi/implementation/kombu.svg
:alt: Support Python implementations.
- :target: http://pypi.python.org/pypi/kombu/
+ :target: https://pypi.python.org/pypi/kombu/
--
diff --git a/docs/includes/introduction.txt b/docs/includes/introduction.txt
index efed1cf3..319a4f03 100644
--- a/docs/includes/introduction.txt
+++ b/docs/includes/introduction.txt
@@ -56,12 +56,12 @@ Features
For an introduction to AMQP you should read the article `Rabbits and warrens`_,
and the `Wikipedia article about AMQP`_.
-.. _`RabbitMQ`: http://www.rabbitmq.com/
-.. _`AMQP`: http://amqp.org
-.. _`py-amqp`: http://pypi.python.org/pypi/amqp/
-.. _`qpid-python`: http://pypi.python.org/pypi/qpid-python/
-.. _`Redis`: http://code.google.com/p/redis/
-.. _`Amazon SQS`: http://aws.amazon.com/sqs/
+.. _`RabbitMQ`: https://www.rabbitmq.com/
+.. _`AMQP`: https://amqp.org
+.. _`py-amqp`: https://pypi.python.org/pypi/amqp/
+.. _`qpid-python`: https://pypi.python.org/pypi/qpid-python/
+.. _`Redis`: https://redis.io/
+.. _`Amazon SQS`: https://aws.amazon.com/sqs/
.. _`Zookeeper`: https://zookeeper.apache.org/
.. _`Rabbits and warrens`: http://blogs.digitar.com/jjww/2009/01/rabbits-and-warrens/
.. _`amqplib`: http://barryp.org/software/py-amqplib/
diff --git a/kombu/clocks.py b/kombu/clocks.py
index 3de05c0f..cd458f62 100644
--- a/kombu/clocks.py
+++ b/kombu/clocks.py
@@ -90,8 +90,8 @@ class LamportClock(object):
* `Lamports distributed mutex`_
- .. _`Lamport Timestamps`: http://en.wikipedia.org/wiki/Lamport_timestamps
- .. _`Lamports distributed mutex`: http://bit.ly/p99ybE
+ .. _`Lamport Timestamps`: https://en.wikipedia.org/wiki/Lamport_timestamps
+ .. _`Lamports distributed mutex`: https://bit.ly/p99ybE
*Usage*
diff --git a/kombu/compat.py b/kombu/compat.py
index 83634195..705e16bf 100644
--- a/kombu/compat.py
+++ b/kombu/compat.py
@@ -1,6 +1,6 @@
"""Carrot compatibility interface.
-See http://packages.python.org/pypi/carrot for documentation.
+See https://pypi.python.org/pypi/carrot for documentation.
"""
from __future__ import absolute_import, unicode_literals
diff --git a/kombu/serialization.py b/kombu/serialization.py
index b21c424c..e05ae67e 100644
--- a/kombu/serialization.py
+++ b/kombu/serialization.py
@@ -358,7 +358,7 @@ def register_msgpack():
"""Register msgpack serializer.
See Also:
- http://msgpack.sourceforge.net/.
+ https://msgpack.org/.
"""
pack = unpack = None
try:
diff --git a/kombu/transport/SQS.py b/kombu/transport/SQS.py
index e8e8b1c0..c14a142a 100644
--- a/kombu/transport/SQS.py
+++ b/kombu/transport/SQS.py
@@ -9,7 +9,7 @@ task queue situations where tasks are small, idempotent and run very fast.
SQS Features supported by this transport:
Long Polling:
- http://docs.aws.amazon.com/AWSSimpleQueueService/latest/SQSDeveloperGuide/
+ https://docs.aws.amazon.com/AWSSimpleQueueService/latest/SQSDeveloperGuide/
sqs-long-polling.html
Long polling is enabled by setting the `wait_time_seconds` transport
@@ -17,7 +17,7 @@ SQS Features supported by this transport:
enabled with 10 seconds by default.
Batch API Actions:
- http://docs.aws.amazon.com/AWSSimpleQueueService/latest/SQSDeveloperGuide/
+ https://docs.aws.amazon.com/AWSSimpleQueueService/latest/SQSDeveloperGuide/
sqs-batch-api.html
The default behavior of the SQS Channel.drain_events() method is to
diff --git a/kombu/transport/librabbitmq.py b/kombu/transport/librabbitmq.py
index 8d91e474..d28910af 100644
--- a/kombu/transport/librabbitmq.py
+++ b/kombu/transport/librabbitmq.py
@@ -1,6 +1,6 @@
"""`librabbitmq`_ transport.
-.. _`librabbitmq`: http://pypi.python.org/librabbitmq/
+.. _`librabbitmq`: https://pypi.python.org/librabbitmq/
"""
from __future__ import absolute_import, unicode_literals
diff --git a/kombu/transport/mongodb.py b/kombu/transport/mongodb.py
index 2e32e048..2a7f8ff3 100644
--- a/kombu/transport/mongodb.py
+++ b/kombu/transport/mongodb.py
@@ -239,7 +239,7 @@ class Channel(virtual.Channel):
def _parse_uri(self, scheme='mongodb://'):
# See mongodb uri documentation:
- # http://docs.mongodb.org/manual/reference/connection-string/
+ # https://docs.mongodb.org/manual/reference/connection-string/
client = self.connection.client
hostname = client.hostname
diff --git a/kombu/transport/qpid.py b/kombu/transport/qpid.py
index 22046241..b9443a49 100644
--- a/kombu/transport/qpid.py
+++ b/kombu/transport/qpid.py
@@ -23,9 +23,9 @@ or to install the requirements manually:
to underlying dependencies not being compatible. This version is
tested and works with with Python 2.7.
-.. _`Qpid`: http://qpid.apache.org/
-.. _`qpid-python`: http://pypi.python.org/pypi/qpid-python/
-.. _`qpid-tools`: http://pypi.python.org/pypi/qpid-tools/
+.. _`Qpid`: https://qpid.apache.org/
+.. _`qpid-python`: https://pypi.python.org/pypi/qpid-python/
+.. _`qpid-tools`: https://pypi.python.org/pypi/qpid-tools/
Authentication
==============
diff --git a/kombu/utils/limits.py b/kombu/utils/limits.py
index 65c574ba..1a9ee3b6 100644
--- a/kombu/utils/limits.py
+++ b/kombu/utils/limits.py
@@ -12,10 +12,10 @@ class TokenBucket(object):
"""Token Bucket Algorithm.
See Also:
- http://en.wikipedia.org/wiki/Token_Bucket
+ https://en.wikipedia.org/wiki/Token_Bucket
Most of this code was stolen from an entry in the ASPN Python Cookbook:
- http://code.activestate.com/recipes/511490/
+ https://code.activestate.com/recipes/511490/
Warning:
Thread Safety: This implementation is not thread safe.
diff --git a/setup.py b/setup.py
index a1b65879..21d7f8ab 100644
--- a/setup.py
+++ b/setup.py
@@ -82,7 +82,7 @@ for dirpath, dirnames, filenames in os.walk(src_dir):
if os.path.exists('README.rst'):
long_description = codecs.open('README.rst', 'r', 'utf-8').read()
else:
- long_description = 'See http://pypi.python.org/pypi/kombu'
+ long_description = 'See https://pypi.python.org/pypi/kombu'
# -*- Installation Requires -*-
py_version = sys.version_info