summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README.rst10
-rw-r--r--docs/includes/introduction.txt2
-rw-r--r--kombu/__init__.py2
3 files changed, 11 insertions, 3 deletions
diff --git a/README.rst b/README.rst
index 81e6783c..bd4e7201 100644
--- a/README.rst
+++ b/README.rst
@@ -4,7 +4,7 @@
|build-status| |coverage| |license| |wheel| |pyversion| |pyimp|
-:Version: 4.0.0rc4
+:Version: 4.0.0rc5
:Web: http://kombu.me/
:Download: http://pypi.python.org/pypi/kombu/
:Source: https://github.com/celery/kombu/
@@ -34,6 +34,7 @@ Features
* High performance AMQP transport written in C - when using `librabbitmq`_
This is automatically enabled if librabbitmq is installed:
+
::
$ pip install librabbitmq
@@ -122,6 +123,7 @@ Kombu is using Sphinx, and the latest documentation can be found here:
Quick overview
--------------
+
::
from kombu import Connection, Exchange, Queue
@@ -166,6 +168,7 @@ Quick overview
Or handle channels manually:
+
::
with connection.channel() as channel:
@@ -175,6 +178,7 @@ Or handle channels manually:
All objects can be used outside of with statements too,
just remember to close the objects after use:
+
::
from kombu import Connection, Consumer, Producer
@@ -198,6 +202,7 @@ to a channel.
Binding exchanges and queues to a connection will make it use
that connections default channel.
+
::
>>> exchange = Exchange('tasks', 'direct')
@@ -276,17 +281,20 @@ You can install `Kombu` either via the Python Package Index (PyPI)
or from source.
To install using `pip`,:
+
::
$ pip install kombu
To install using `easy_install`,:
+
::
$ easy_install kombu
If you have downloaded a source tarball you can install it
by doing the following,:
+
::
$ python setup.py build
diff --git a/docs/includes/introduction.txt b/docs/includes/introduction.txt
index 3bf31de9..07a70749 100644
--- a/docs/includes/introduction.txt
+++ b/docs/includes/introduction.txt
@@ -1,4 +1,4 @@
-:Version: 4.0.0rc4
+:Version: 4.0.0rc5
:Web: http://kombu.me/
:Download: http://pypi.python.org/pypi/kombu/
:Source: https://github.com/celery/kombu/
diff --git a/kombu/__init__.py b/kombu/__init__.py
index ab2789ba..62eea6f7 100644
--- a/kombu/__init__.py
+++ b/kombu/__init__.py
@@ -10,7 +10,7 @@ if sys.version_info < (2, 7): # pragma: no cover
from collections import namedtuple # noqa
-__version__ = '4.0.0rc4'
+__version__ = '4.0.0rc5'
__author__ = 'Ask Solem'
__contact__ = 'ask@celeryproject.org'
__homepage__ = 'https://kombu.readthedocs.io'