summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2016-10-11 12:33:31 -0700
committerAsk Solem <ask@celeryproject.org>2016-10-11 12:33:31 -0700
commit836512cadd23c96f23bbb5cd8f4a1bf83c36ab19 (patch)
tree4e308d8dde1d96295de0d2961d31f443fdd02471 /Makefile
parent4f4738cf63190083517e226b7ff8185415ee525f (diff)
downloadkombu-836512cadd23c96f23bbb5cd8f4a1bf83c36ab19.tar.gz
Adds pydocstyle as a tox target
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 60d6a10d..4082e006 100644
--- a/Makefile
+++ b/Makefile
@@ -5,6 +5,7 @@ PYTEST=py.test
GIT=git
TOX=tox
ICONV=iconv
+PYDOCSTYLE=pydocstyle
FLAKE8=flake8
FLAKEPLUS=flakeplus
SPHINX2RST=sphinx2rst
@@ -35,6 +36,7 @@ help:
@echo " flakes -------- - Check code for syntax and style errors."
@echo " flakecheck - Run flake8 on the source code."
@echo " flakepluscheck - Run flakeplus on the source code."
+ @echo " pep257check - Run pep257 on the source code."
@echo "readme - Regenerate README.rst file."
@echo "contrib - Regenerate CONTRIBUTING.rst file"
@echo "clean-dist --------- - Clean all distribution build artifacts."
@@ -95,7 +97,10 @@ flakepluscheck:
flakeplusdiag:
-$(MAKE) flakepluscheck
-flakes: flakediag flakeplusdiag
+pep257check:
+ $(PYDOCSTYLE) --ignore=D102,D104,D203,D105 "$(PROJ)"
+
+flakes: flakediag flakeplusdiag pep257check
clean-readme:
-rm -f $(README)