summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStevie Gayet <87695919+stegayet@users.noreply.github.com>2023-05-14 17:12:24 +0200
committerGitHub <noreply@github.com>2023-05-14 21:12:24 +0600
commit8426032ae25b6e35bbb72fe084281a447d30991f (patch)
tree71d34e5d01af2cc42125a52645fad6f9f058b694
parentae64a9f8eee73f9a7528f7f50dc3c10e5e20dce4 (diff)
downloadkombu-8426032ae25b6e35bbb72fe084281a447d30991f.tar.gz
chore(build): clean `setup.py` (#1711)
* chore(build): remove deprecated `zip_safe` parameter * chore(build): remove `cmdclass` parameter --------- Co-authored-by: Stevie Gayet <stegayet@users.noreply.github.com>
-rw-r--r--setup.py15
1 files changed, 0 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 8e15d1e9..50de0cc5 100644
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,6 @@ import re
import sys
import setuptools
-import setuptools.command.test
try:
from setuptools import setup
@@ -80,18 +79,6 @@ def extras(*p):
return reqs('extras', *p)
-class pytest(setuptools.command.test.test):
- user_options = [('pytest-args=', 'a', 'Arguments to pass to py.test')]
-
- def initialize_options(self):
- super().initialize_options()
- self.pytest_args = []
-
- def run_tests(self):
- import pytest
- sys.exit(pytest.main(self.pytest_args))
-
-
def readme():
with open('README.rst') as f:
return f.read()
@@ -110,9 +97,7 @@ setup(
'Source': 'https://github.com/celery/kombu'
},
platforms=['any'],
- zip_safe=False,
license='BSD-3-Clause',
- cmdclass={'test': pytest},
python_requires=">=3.7",
install_requires=reqs('default.txt'),
tests_require=reqs('test.txt'),