summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsk Solem <ask@celeryproject.org>2016-10-11 12:48:50 -0700
committerAsk Solem <ask@celeryproject.org>2016-10-11 12:48:50 -0700
commit0cc7a517fa31493a2700e13ddbab36b82b0d7e45 (patch)
treef94b7b493022550d67cf6ef3c24f0dc5b33cfe14
parent836512cadd23c96f23bbb5cd8f4a1bf83c36ab19 (diff)
downloadkombu-0cc7a517fa31493a2700e13ddbab36b82b0d7e45.tar.gz
Fixes flakes
-rw-r--r--Makefile2
-rw-r--r--requirements/pkgutils.txt1
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4082e006..5dc04cd8 100644
--- a/Makefile
+++ b/Makefile
@@ -86,7 +86,7 @@ configcheck:
(cd "$(SPHINX_DIR)"; $(MAKE) configcheck)
flakecheck:
- $(FLAKE8) --ignore=X999 "$(PROJ)" "$(TESTDIR)"
+ $(FLAKE8) "$(PROJ)" "$(TESTDIR)"
flakediag:
-$(MAKE) flakecheck
diff --git a/requirements/pkgutils.txt b/requirements/pkgutils.txt
index ef39a5df..85b4d080 100644
--- a/requirements/pkgutils.txt
+++ b/requirements/pkgutils.txt
@@ -5,3 +5,4 @@ flakeplus>=1.1
tox>=2.3.1
sphinx2rst>=1.0
bumpversion
+pep257
diff --git a/tox.ini b/tox.ini
index f57a4ee2..25541697 100644
--- a/tox.ini
+++ b/tox.ini
@@ -49,7 +49,7 @@ commands = pip install -U -r{toxinidir}/requirements/dev.txt
[testenv:flake8]
commands =
- flake8 --ignore=X999 {toxinidir}/kombu {toxinidir}/t
+ flake8 {toxinidir}/kombu {toxinidir}/t
[testenv:flakeplus]
commands =