summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 9db4899..0ec882e 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,3 +3,21 @@ build-backend = 'setuptools.build_meta'
requires = [
'setuptools >= 46.4.0',
]
+
+[tool.black]
+line-length = 79
+target-version = ['py37', 'py38', 'py39', 'py310']
+include = '\.pyi?$'
+# 'extend-exclude' excludes files or directories in addition to the defaults
+# A regex preceded with ^/ will apply only to files and directories
+# in the root of the project.
+# (
+# ^/foo.py # exclude a file named foo.py in the root of the project.
+# | .*_pb2.py # exclude autogenerated Protocol Buffer files anywhere in the
+# )
+# # project.
+extend-exclude = '''
+'''
+
+[tool.pytest.ini_options]
+addopts = "-ra -v"