summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Schlichting <hanno@hannosch.eu>2017-07-24 21:12:48 +0200
committerHanno Schlichting <hanno@hannosch.eu>2017-07-24 21:36:44 +0200
commit698873a6cbcef61615a0e39d09134eff1f367a94 (patch)
treec800abe16a2525251811071c108d631da524e3c7
parent4ebeb1550b8e1adc9fe278efd07b2ff4694b011f (diff)
downloadkazoo-462-virtualenv-continued.tar.gz
Remove unused GEVENT_VERSION env variable.462-virtualenv-continued
-rw-r--r--Makefile2
-rw-r--r--kazoo/tests/test_build.py9
2 files changed, 0 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 677c366..61fbc41 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,6 @@ INSTALL = $(BIN)/pip install
TOX_VENV ?= py27
BUILD_DIRS = bin build include lib lib64 man share
-GEVENT_VERSION ?= 1.0.1
PYTHON_EXE = $(shell [ -f $(PYTHON) ] && echo $(PYTHON) || echo python)
PYPY = $(shell $(PYTHON_EXE) -c "import sys; print(getattr(sys, 'pypy_version_info', False) and 'yes' or 'no')")
TRAVIS ?= false
@@ -33,7 +32,6 @@ build: $(PYTHON)
ifeq ($(GREENLET_SUPPORTED),yes)
$(INSTALL) -U -r requirements_eventlet.txt
$(INSTALL) -U -r requirements_gevent.txt
- $(INSTALL) -f https://github.com/surfly/gevent/releases gevent==$(GEVENT_VERSION)
endif
ifneq ($(TRAVIS), true)
$(INSTALL) -U -r requirements_sphinx.txt
diff --git a/kazoo/tests/test_build.py b/kazoo/tests/test_build.py
index 0f778a6..b8e4bbc 100644
--- a/kazoo/tests/test_build.py
+++ b/kazoo/tests/test_build.py
@@ -12,15 +12,6 @@ class TestBuildEnvironment(KazooTestCase):
if not os.environ.get('TRAVIS'):
raise SkipTest('Only run build config tests on Travis.')
- def test_gevent_version(self):
- try:
- import gevent
- except ImportError:
- raise SkipTest('gevent not available.')
- env_version = os.environ.get('GEVENT_VERSION')
- if env_version:
- self.assertEqual(env_version, gevent.__version__)
-
def test_zookeeper_version(self):
server_version = self.client.server_version()
server_version = '.'.join([str(i) for i in server_version])