summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Arthur <mumrah@gmail.com>2014-08-22 13:44:16 -0400
committerDavid Arthur <mumrah@gmail.com>2014-08-22 13:46:38 -0400
commitf8618336979fd2704d14695750b6a240b3922d40 (patch)
tree3db4e4d62191e73acf5c0aa70677779545d5e175
parent69b55c9806a46b99788f653ddb83e595c2ad227c (diff)
downloadkafka-python-f8618336979fd2704d14695750b6a240b3922d40.tar.gz
Add TravisCI config for auto deployment
Tags applied to master will now be automatically deployed on PyPI
-rw-r--r--.travis.yml17
-rw-r--r--LICENSE2
-rw-r--r--kafka/__init__.py2
-rw-r--r--setup.py12
4 files changed, 24 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index 23c0dcc..8eaaad6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -22,10 +22,17 @@ install:
# See https://github.com/travis-ci/travis-cookbooks/issues/155
- sudo rm -rf /dev/shm && sudo ln -s /run/shm /dev/shm
+deploy:
+ provider: pypi
+ server: https://pypi.python.org/pypi
+ user: mumrah
+ password:
+ secure: TIZNKxktOm42/LHLDCuKuPqmAfYKekyHL4MqEFpnqDI5T5sHzG9IQaOwppYfQNggHiILUBzk1j6w/FPJunJyd62AFtydkKtIccqENIIAio78afeCRMQDynstNXjDefmt0s90xLGSlLzDMxCEWB4F6frEtPl/8KpNSFB2fvj+HXY=
+ on:
+ tags: true
+ all_branches: true
+ # TODO replace all_branches with "branch: master" after https://github.com/travis-ci/travis-ci/issues/1675 is fixed
+ # branch: master
+
script:
- tox -e `./travis_selector.sh $TRAVIS_PYTHON_VERSION`
-
-branches:
- only:
- - master
- - /^release-.*$/
diff --git a/LICENSE b/LICENSE
index efe9d96..f1b6938 100644
--- a/LICENSE
+++ b/LICENSE
@@ -186,7 +186,7 @@
same "printed page" as the copyright notice for easier
identification within third-party archives.
- Copyright 2013 David Arthur
+ Copyright 2014 David Arthur
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
diff --git a/kafka/__init__.py b/kafka/__init__.py
index 41dc25a..58ca619 100644
--- a/kafka/__init__.py
+++ b/kafka/__init__.py
@@ -4,7 +4,7 @@ import pkg_resources
__version__ = pkg_resources.require('kafka-python')[0].version
__author__ = 'David Arthur'
__license__ = 'Apache License 2.0'
-__copyright__ = 'Copyright 2012, David Arthur under Apache License, v2.0'
+__copyright__ = 'Copyright 2014, David Arthur under Apache License, v2.0'
from kafka.client import KafkaClient
from kafka.conn import KafkaConnection
diff --git a/setup.py b/setup.py
index d719bf4..e69323b 100644
--- a/setup.py
+++ b/setup.py
@@ -32,12 +32,20 @@ setup(
author="David Arthur",
author_email="mumrah@gmail.com",
url="https://github.com/mumrah/kafka-python",
- license="Copyright 2012, David Arthur under Apache License, v2.0",
+ license="Apache License 2.0",
description="Pure Python client for Apache Kafka",
long_description="""
This module provides low-level protocol support for Apache Kafka as well as
high-level consumer and producer classes. Request batching is supported by the
protocol as well as broker-aware request routing. Gzip and Snappy compression
is also supported for message sets.
-"""
+""",
+ keywords="apache kafka",
+ classifiers = [
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Apache Software License",
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Libraries :: Python Modules"
+ ]
)