summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSwen Kooij <swenkooij@gmail.com>2020-07-23 09:51:17 +0300
committerGitHub <noreply@github.com>2020-07-22 23:51:17 -0700
commitbd557dabd487cc44c11bf003600c82477ea5de11 (patch)
tree456e71a2d9ca5d72949de649613949668a442260
parent316da747e432962d149828cb9d6fbaff04c2008c (diff)
downloadkafka-python-bd557dabd487cc44c11bf003600c82477ea5de11.tar.gz
Python 3.8 support (#2088)
-rw-r--r--.travis.yml1
-rw-r--r--docs/compatibility.rst2
-rw-r--r--requirements-dev.txt8
-rw-r--r--setup.py1
-rw-r--r--tox.ini8
5 files changed, 11 insertions, 9 deletions
diff --git a/.travis.yml b/.travis.yml
index b98aa16..d660271 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,7 @@ python:
- 2.7
- 3.4
- 3.7
+ - 3.8
- pypy2.7-6.0
env:
diff --git a/docs/compatibility.rst b/docs/compatibility.rst
index 93be6fd..ae15261 100644
--- a/docs/compatibility.rst
+++ b/docs/compatibility.rst
@@ -16,6 +16,6 @@ Although kafka-python is tested and expected to work on recent broker versions,
not all features are supported. Specifically, authentication codecs, and
transactional producer/consumer support are not fully implemented. PRs welcome!
-kafka-python is tested on python 2.7, 3.4, 3.7, and pypy2.7.
+kafka-python is tested on python 2.7, 3.4, 3.7, 3.8 and pypy2.7.
Builds and tests via Travis-CI. See https://travis-ci.org/dpkp/kafka-python
diff --git a/requirements-dev.txt b/requirements-dev.txt
index d283090..6c3a666 100644
--- a/requirements-dev.txt
+++ b/requirements-dev.txt
@@ -1,6 +1,6 @@
flake8==3.4.1
-pytest==3.10.0
-pytest-cov==2.6.0
+pytest==5.4.3
+pytest-cov==2.10.0
docker-py==1.10.6
coveralls==1.5.1
Sphinx==1.6.4
@@ -9,8 +9,8 @@ xxhash==1.3.0
python-snappy==0.5.3
tox==3.5.3
mock==3.0.5
-pylint==1.9.3
-pytest-pylint==0.12.3
+pylint==2.5.3
+pytest-pylint==0.17.0
pytest-mock==1.10.0
sphinx-rtd-theme==0.2.4
crc32c==1.7
diff --git a/setup.py b/setup.py
index 8bc484c..005c5ad 100644
--- a/setup.py
+++ b/setup.py
@@ -56,6 +56,7 @@ setup(
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
"Programming Language :: Python :: Implementation :: PyPy",
"Topic :: Software Development :: Libraries :: Python Modules",
]
diff --git a/tox.ini b/tox.ini
index 06403d6..8dfe2c5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py{26,27,34,35,36,37,py}, docs
+envlist = py{26,27,34,35,36,37,38,py}, docs
[pytest]
testpaths = kafka test
@@ -8,10 +8,10 @@ log_format = %(created)f %(filename)-23s %(threadName)s %(message)s
[testenv]
deps =
- pytest<4.0
+ pytest
pytest-cov
- py{27,34,35,36,37,py}: pylint
- py{27,34,35,36,37,py}: pytest-pylint
+ py{27,34,35,36,37,38,py}: pylint
+ py{27,34,35,36,37,38,py}: pytest-pylint
pytest-mock
mock
python-snappy