summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcatchjosh <catchjosh@ae587032-bbab-11de-869a-473eb4776397>2009-10-19 03:11:18 +0000
committercatchjosh <catchjosh@ae587032-bbab-11de-869a-473eb4776397>2009-10-19 03:11:18 +0000
commitd1552931885510d2e984dbe1c12084e46ce14d2e (patch)
tree5ad6e637b531550aefabfe8f4a0eb117d76e8068 /setup.py
parent25cdc01f9427dcc3383d32c53164baf052d1131e (diff)
downloadjsonrpclib-d1552931885510d2e984dbe1c12084e46ce14d2e.tar.gz
Added setup, moved library into lib.
git-svn-id: http://jsonrpclib.googlecode.com/svn/trunk@9 ae587032-bbab-11de-869a-473eb4776397
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..2c8f8c2
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/env/python
+"""
+Copyright 2009 Josh Marshall
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
+"""
+
+import distutils.core
+
+distutils.core.setup(
+ name = "jsonrpclib",
+ version = "0.1",
+ package_dir = {'': 'lib'},
+ py_modules = ["jsonrpclib"],
+ author = "Josh Marshall",
+ author_email = "catchjosh@gmail.com",
+ url = "http://code.google.com/p/jsonrpclib/",
+ license = "http://www.apache.org/licenses/LICENSE-2.0",
+ description = "This project is an implementation of the JSON-RPC v2.0 " +
+ "specification (backwards-compatible) as a client library.",
+)