summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJoshua Marshall <catchjosh@gmail.com>2015-10-08 20:55:49 -0500
committerJoshua Marshall <catchjosh@gmail.com>2015-10-08 20:55:49 -0500
commitafa0ff3aefebd931976e3b353e5f7d14267176b8 (patch)
tree416eb9134698f63bd426cbf50936e60b4e430a08 /setup.py
parentb75d6effd0cd0efdb45e268dbfb020f1e7cca1a9 (diff)
downloadjsonrpclib-afa0ff3aefebd931976e3b353e5f7d14267176b8.tar.gz
Making README.md optional.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py28
1 files changed, 17 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 10d8352..bedfdf5 100755
--- a/setup.py
+++ b/setup.py
@@ -14,16 +14,22 @@ limitations under the License.
"""
import distutils.core
+import os
+
+long_description = "Placeholder in case of missing README.md."
+
+if os.path.exists("README.md"):
+ with open("README.md") as readme_fp:
+ long_description = readme_fp.read()
distutils.core.setup(
- name = "jsonrpclib",
- version = "0.1.5",
- packages = ["jsonrpclib"],
- author = "Josh Marshall",
- author_email = "catchjosh@gmail.com",
- url = "http://github.com/joshmarshall/jsonrpclib/",
- license = "http://www.apache.org/licenses/LICENSE-2.0",
- description = "This project is an implementation of the JSON-RPC v2.0 " +
- "specification (backwards-compatible) as a client library.",
- long_description = open("README.md").read()
-)
+ name="jsonrpclib",
+ version="0.1.5",
+ packages=["jsonrpclib"],
+ author="Josh Marshall",
+ author_email="catchjosh@gmail.com",
+ url="http://github.com/joshmarshall/jsonrpclib/",
+ license="http://www.apache.org/licenses/LICENSE-2.0",
+ description="This project is an implementation of the JSON-RPC v2.0 " +
+ "specification (backwards-compatible) as a client library.",
+ long_description=long_description)