summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorJosh Marshall <catchjosh@gmail.com>2011-02-26 14:49:36 -0600
committerJosh Marshall <catchjosh@gmail.com>2011-02-26 14:49:36 -0600
commitefcf5eee0e12ef8a148caaa9f16db1b0bd009cbb (patch)
tree51f221876ec5b65d768da6fb305d3245953becc3 /README.md
parent3291ce42501a715ae9cacf85dbe89c42b059fd3a (diff)
downloadjsonrpclib-efcf5eee0e12ef8a148caaa9f16db1b0bd009cbb.tar.gz
Adding updates for PyPI submission.
Diffstat (limited to 'README.md')
-rw-r--r--README.md18
1 files changed, 17 insertions, 1 deletions
diff --git a/README.md b/README.md
index 9d431a4..85a157e 100644
--- a/README.md
+++ b/README.md
@@ -42,6 +42,22 @@ should already have one. Keep in mind that cjson is supposed to be the
quickest, I believe, so if you are going for full-on optimization you may
want to pick it up.
+Installation
+------------
+You can install this from PyPI with one of the following commands (sudo
+may be required):
+
+ easy_install jsonrpclib
+ pip install jsonrpclib
+
+Alternatively, you can download the source from the github repository
+at http://github.com/joshmarshall/jsonrpclib and manually install it
+with the following commands:
+
+ git clone git://github.com/joshmarshall/jsonrpclib.git
+ cd jsonrpclib
+ python setup.py install
+
Client Usage
------------
@@ -200,4 +216,4 @@ You can run it with:
TODO
----
* Use HTTP error codes on SimpleJSONRPCServer
-* Test, test, test and optimize \ No newline at end of file
+* Test, test, test and optimize