summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Marshall <catchjosh@gmail.com>2021-03-31 15:51:05 +0900
committerJosh Marshall <catchjosh@gmail.com>2021-03-31 15:51:05 +0900
commita41dbbd1a392b16457f1105db3f1b690efa53d7a (patch)
treed6b48e04c1d65910a5f18738160e2346339441a3
parent4182082b0d5b503146d5dcab49fd9e4afd0e9e48 (diff)
downloadjsonrpclib-a41dbbd1a392b16457f1105db3f1b690efa53d7a.tar.gz
Using pyproject / static setuptools config.
-rw-r--r--pyproject.toml6
-rw-r--r--setup.cfg13
-rwxr-xr-xsetup.py36
3 files changed, 19 insertions, 36 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..4cadba8
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,6 @@
+[build-system]
+requires = [
+ "setuptools>=42",
+ "wheel"
+]
+build-backend = "setuptools.build_meta"
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..13d6b31
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,13 @@
+[metadata]
+name = jsonrpclib
+version = 0.2.1
+author = Josh Marshall
+author_email = catchjosh@gmail.com
+url = https://github.com/joshmarshall/jsonrpclib
+long_description = file: README.md
+long_description_content_type = text/markdown
+description = Implementation of the JSON-RPC v2.0 specification (backwards-compatible) as a client library.
+
+[options]
+packages = jsonrpclib
+python_requires = >=3.5
diff --git a/setup.py b/setup.py
deleted file mode 100755
index bd9f79a..0000000
--- a/setup.py
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/usr/bin/env python
-"""
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS,
-WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-See the License for the specific language governing permissions and
-limitations under the License.
-"""
-
-import distutils.core
-import os
-
-long_description = "Placeholder in case of missing README.md."
-
-if os.path.exists("README.md"):
- with open("README.md") as readme_fp:
- long_description = readme_fp.read()
-
-distutils.core.setup(
- name="jsonrpclib",
- version="0.2.1",
- packages=["jsonrpclib"],
- author="Josh Marshall",
- author_email="catchjosh@gmail.com",
- url="http://github.com/joshmarshall/jsonrpclib/",
- license="http://www.apache.org/licenses/LICENSE-2.0",
- description="This project is an implementation of the JSON-RPC v2.0 " +
- "specification (backwards-compatible) as a client library.",
- long_description=long_description,
- long_description_content_type="text/markdown")