summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosh Marshall <catchjosh@gmail.com>2021-03-31 16:32:36 +0900
committerJosh Marshall <catchjosh@gmail.com>2021-03-31 16:32:36 +0900
commit0177d6df38a4587060f179b62164ea65822d9846 (patch)
tree32a7d96bc7efd668b4772b65ee1bc47912658650
parentba392d465e130ece0b6ac229457117a55def613c (diff)
downloadjsonrpclib-0177d6df38a4587060f179b62164ea65822d9846.tar.gz
Removing references to setup.py in Circle config.
-rw-r--r--.circleci/config.yml4
1 files changed, 2 insertions, 2 deletions
diff --git a/.circleci/config.yml b/.circleci/config.yml
index dbfea8e..ec9f2ad 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -14,7 +14,7 @@ jobs:
command: pip3 install -r dev-requirements.txt
- run:
name: Install CI dependencies
- command: pip3 install tox twine tox-pyenv
+ command: pip3 install tox twine tox-pyenv build
- run: pyenv install --skip-existing 3.5-dev
- run: pyenv install --skip-existing 3.6-dev
- run: pyenv install --skip-existing 3.7-dev
@@ -39,7 +39,7 @@ jobs:
- store_test_results:
path: reports
- run:
- command: python3 setup.py sdist
+ command: python3 -m build
name: Build source distribution
- store_artifacts:
path: ./dist