summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenn Knowles <kenn@kennknowles.com>2019-11-13 22:45:12 -0800
committerGitHub <noreply@github.com>2019-11-13 22:45:12 -0800
commitb008a97c247cd0f309e85db98e37d0c14e8dc81c (patch)
tree3cee1f94def317eb790c436c274741140a350002
parentf615451d7b405e23e0f80b15cad03b1427b0256d (diff)
parentf2ded16174d6b8fa2acdbb00585e645a42eeaab8 (diff)
downloadjsonpath-rw-b008a97c247cd0f309e85db98e37d0c14e8dc81c.tar.gz
Merge pull request #75: Fixed TravisCI build
-rw-r--r--.travis.yml14
-rw-r--r--README.rst3
2 files changed, 7 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 8aa387e..be321f3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,11 @@
language: python
python:
- "2.7"
- - "3.2"
- - "3.3"
- "3.4"
- "3.5"
- "3.6"
+ - "pypy"
+ - "pypy3"
# Enable 3.7 without globally enabling sudo and dist: xenial for other build jobs
matrix:
include:
@@ -13,12 +13,10 @@ matrix:
dist: xenial
sudo: true
install:
- - "pip install ."
- - "pip install pytest"
- - "pip install coveralls"
- # Coveralls 4.0 doesn't support Python 3.2
- - if [ "$TRAVIS_PYTHON_VERSION" == "3.2" ]; then pip install coverage==3.7.1; fi
- - if [ "$TRAVIS_PYTHON_VERSION" != "3.2" ]; then pip install coverage; fi
+ - pip install .
+ - pip install pytest
+ - pip install coveralls
+ - pip install coverage
script: coverage run setup.py test
after_success:
- coveralls
diff --git a/README.rst b/README.rst
index dc6856e..dc85c19 100644
--- a/README.rst
+++ b/README.rst
@@ -6,8 +6,7 @@ https://github.com/kennknowles/python-jsonpath-rw
|Build Status| |Test coverage| |PyPi version| |PyPi downloads|
This library provides a robust and significantly extended implementation
-of JSONPath for Python. It is tested with Python 2.7, 3.2, 3.3, 3.4, 3.5, 3.6, and 3.7.
-*(On travis-ci there is a segfault when running the tests with pypy; I don't think the problem lies with this library)*.
+of JSONPath for Python. It is tested with Python 2.7, 3.4, 3.5, 3.6, 3.7, pypy and pypy3.
This library differs from other JSONPath implementations in that it is a
full *language* implementation, meaning the JSONPath expressions are