summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Kelly <skelly@dimagi.com>2018-07-27 15:16:49 +0200
committerSimon Kelly <skelly@dimagi.com>2018-07-27 15:16:49 +0200
commit320deb5c3a4791b3024bc305f97d2b6c1a53936f (patch)
tree84ba43f8c612e734d31ee6fc4ad3180b335fac54
parent1310c0c63d3db1ff3eea36501f7d68958eae5f8b (diff)
downloadjsonpath-rw-320deb5c3a4791b3024bc305f97d2b6c1a53936f.tar.gz
fix python 3.2 build
-rw-r--r--.travis.yml5
1 files changed, 4 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 8c18230..3c55ece 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,7 +8,10 @@ python:
install:
- "pip install ."
- "pip install pytest"
- - "pip install coverage coveralls"
+ - "pip install coveralls"
+ # Coveralls 4.0 doesn't support Python 3.2
+ - if [ "$TRAVIS_PYTHON_VERSION" == "3.2" ]; then pip install coverage==3.7.1; fi
+ - if [ "$TRAVIS_PYTHON_VERSION" != "3.2" ]; then pip install coverage; fi
script: coverage run setup.py test
after_success:
- coveralls