summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Iljushkin <ailjushkin@gmail.com>2019-10-13 11:06:04 +0300
committerAlexander Iljushkin <ailjushkin@gmail.com>2019-10-13 11:06:04 +0300
commit0a11e440bf28e2b8861d0b2608bcdd5e6dff2a9e (patch)
tree7c14d99482c1968825e385c8b726f94a157e9904
parentf615451d7b405e23e0f80b15cad03b1427b0256d (diff)
downloadjsonpath-rw-0a11e440bf28e2b8861d0b2608bcdd5e6dff2a9e.tar.gz
Fixed travis build
-rw-r--r--.travis.yml14
1 files changed, 6 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 8aa387e..be321f3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,11 @@
language: python
python:
- "2.7"
- - "3.2"
- - "3.3"
- "3.4"
- "3.5"
- "3.6"
+ - "pypy"
+ - "pypy3"
# Enable 3.7 without globally enabling sudo and dist: xenial for other build jobs
matrix:
include:
@@ -13,12 +13,10 @@ matrix:
dist: xenial
sudo: true
install:
- - "pip install ."
- - "pip install pytest"
- - "pip install coveralls"
- # Coveralls 4.0 doesn't support Python 3.2
- - if [ "$TRAVIS_PYTHON_VERSION" == "3.2" ]; then pip install coverage==3.7.1; fi
- - if [ "$TRAVIS_PYTHON_VERSION" != "3.2" ]; then pip install coverage; fi
+ - pip install .
+ - pip install pytest
+ - pip install coveralls
+ - pip install coverage
script: coverage run setup.py test
after_success:
- coveralls