summaryrefslogtreecommitdiff
path: root/example_shared_isort_profile
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2020-07-26 01:26:11 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2020-07-26 01:26:11 -0700
commit57eb70a4c70311f6b1748062853ded38f7fec366 (patch)
tree21f59e9948bcbc1276d209a68d597f1e50ec1bb2 /example_shared_isort_profile
parent3972ecc8536677b3499163b3ba1ab7bdc2de9e45 (diff)
downloadisort-57eb70a4c70311f6b1748062853ded38f7fec366.tar.gz
Add test for an example for shared profiles support (issue #970)
Diffstat (limited to 'example_shared_isort_profile')
-rw-r--r--example_shared_isort_profile/example_shared_isort_profile.py7
-rw-r--r--example_shared_isort_profile/poetry.lock7
-rw-r--r--example_shared_isort_profile/pyproject.toml18
3 files changed, 32 insertions, 0 deletions
diff --git a/example_shared_isort_profile/example_shared_isort_profile.py b/example_shared_isort_profile/example_shared_isort_profile.py
new file mode 100644
index 00000000..986ddd5d
--- /dev/null
+++ b/example_shared_isort_profile/example_shared_isort_profile.py
@@ -0,0 +1,7 @@
+PROFILE = {
+ "multi_line_output": 3,
+ "include_trailing_comma": True,
+ "force_grid_wrap": 0,
+ "use_parentheses": True,
+ "line_length": 100,
+}
diff --git a/example_shared_isort_profile/poetry.lock b/example_shared_isort_profile/poetry.lock
new file mode 100644
index 00000000..12fbad91
--- /dev/null
+++ b/example_shared_isort_profile/poetry.lock
@@ -0,0 +1,7 @@
+package = []
+
+[metadata]
+content-hash = "8165d934e932435bf4742b9198674202413b43524911713d5c7c55cb8d314618"
+python-versions = "^3.5"
+
+[metadata.files]
diff --git a/example_shared_isort_profile/pyproject.toml b/example_shared_isort_profile/pyproject.toml
new file mode 100644
index 00000000..7a290ddc
--- /dev/null
+++ b/example_shared_isort_profile/pyproject.toml
@@ -0,0 +1,18 @@
+[tool.poetry]
+name = "example_shared_isort_profile"
+version = "0.0.1"
+description = "An example shared isort profile"
+authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
+license = "MIT"
+
+[tool.poetry.plugins."isort.profiles"]
+example = "example_shared_isort_profile:PROFILE"
+
+[tool.poetry.dependencies]
+python = "^3.6"
+
+[tool.poetry.dev-dependencies]
+
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.masonry.api"