summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2018-09-22 22:01:09 -0700
committerGitHub <noreply@github.com>2018-09-22 22:01:09 -0700
commitcd8398c05d0683630e8b0d704fbacb601d7741bb (patch)
tree132ddd9e36ee4abd31e1bd0d0caedba63a3efd8f
parent786da86718b7f2b8418ab887c811b685b2132782 (diff)
parent482d3b4cea5770413988925035b91d94aae5a743 (diff)
downloadisort-cd8398c05d0683630e8b0d704fbacb601d7741bb.tar.gz
Merge pull request #716 from jdufresne/py37
Add testing and document support for Python 3.7
-rw-r--r--.env4
-rw-r--r--.travis.yml7
-rw-r--r--README.rst2
-rw-r--r--appveyor.yml2
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini4
6 files changed, 13 insertions, 7 deletions
diff --git a/.env b/.env
index 9651d0c5..b9ddb8fe 100644
--- a/.env
+++ b/.env
@@ -16,7 +16,9 @@ if [ ! -d "venv" ]; then
if ! hash pyvenv 2>/dev/null; then
function pyvenv()
{
- if hash pyvenv-3.6 2>/dev/null; then
+ if hash pyvenv-3.7 2>/dev/null; then
+ pyvenv-3.7 $@
+ elif hash pyvenv-3.6 2>/dev/null; then
pyvenv-3.6 $@
elif hash pyvenv-3.5 2>/dev/null; then
pyvenv-3.5 $@
diff --git a/.travis.yml b/.travis.yml
index ae6cbac9..c37cc1fa 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,8 +4,7 @@ cache: pip
matrix:
include:
- env: TOXENV=isort-check
- - python: 3.6
- env: TOXENV=lint
+ - env: TOXENV=lint
- python: 2.7
env: TOXENV=py27
- python: 3.4
@@ -14,6 +13,10 @@ matrix:
env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
+ - python: 3.7
+ env: TOXENV=py37
+ dist: xenial
+ sudo: required
- python: pypy
env: TOXENV=pypy
install:
diff --git a/README.rst b/README.rst
index 05d834d5..d4646f9a 100644
--- a/README.rst
+++ b/README.rst
@@ -29,7 +29,7 @@ isort your python imports for you so you don't have to.
isort is a Python utility / library to sort imports alphabetically, and automatically separated into sections.
It provides a command line utility, Python library and `plugins for various editors <https://github.com/timothycrosley/isort/wiki/isort-Plugins>`_ to quickly sort all your imports.
-It currently cleanly supports Python 2.7 - 3.6 without any dependencies.
+It currently cleanly supports Python 2.7 and 3.4+ without any dependencies.
.. image:: https://raw.github.com/timothycrosley/isort/develop/example.gif
:alt: Example Usage
diff --git a/appveyor.yml b/appveyor.yml
index 48207e2d..11c69a45 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -9,4 +9,4 @@ install:
- pip install tox
test_script:
- - tox -e isort-check,py27,py34,py35,py36
+ - tox -e isort-check,py27,py34,py35,py36,py37
diff --git a/setup.py b/setup.py
index b33f2a48..9332dae5 100755
--- a/setup.py
+++ b/setup.py
@@ -74,6 +74,7 @@ setup(name='isort',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries',
diff --git a/tox.ini b/tox.ini
index 52364e40..7b0e0d31 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,8 +1,8 @@
[tox]
envlist =
isort-check,
- py27, py34, py35, py36, pypy,
- lint
+ lint,
+ py{27,34,35,36,37,py}
[testenv]
deps =