summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaurav Maheshkar <sauravvmaheshkar@gmail.com>2023-03-30 16:46:33 +0100
committerSaurav Maheshkar <sauravvmaheshkar@gmail.com>2023-03-30 16:46:33 +0100
commit906294126b1c0a7a0b13952a88e89dfa10643b92 (patch)
treed41c0b516fdb396a3b28b6cce8760016e13d7b86
parente87ac8dcc67a55295262a7e2158309746612b148 (diff)
downloadisort-906294126b1c0a7a0b13952a88e89dfa10643b92.tar.gz
chore: move isort configuration to pyproject.toml
-rw-r--r--.isort.cfg5
-rw-r--r--pyproject.toml7
2 files changed, 7 insertions, 5 deletions
diff --git a/.isort.cfg b/.isort.cfg
deleted file mode 100644
index 545be979..00000000
--- a/.isort.cfg
+++ /dev/null
@@ -1,5 +0,0 @@
-[settings]
-profile=hug
-src_paths=isort,test
-skip=tests/unit/example_crlf_file.py
-
diff --git a/pyproject.toml b/pyproject.toml
index b21c54a6..be76db94 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -152,3 +152,10 @@ module = "tests.*"
allow_untyped_defs = true
allow_incomplete_defs = true
allow_untyped_calls = true
+
+[tool.isort]
+profile = "hug"
+src_paths = ["isort", "tests"]
+skip = [
+ "tests/unit/example_crlf_file.py"
+]