summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2021-03-20 22:25:02 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2021-03-20 22:25:02 -0700
commita6222a8a125ec719724e628a5d3d0d5c60923281 (patch)
tree2ef955f7d51d368e79b30bb6527a8e98383ecfb5
parent43cfa4752acf9a64124aadfcbc11747afd0d9391 (diff)
downloadisort-master.tar.gz
Bump version to 5.8.05.8.0master
-rw-r--r--CHANGELOG.md2
-rw-r--r--isort/_version.py2
-rw-r--r--isort/settings.py1
-rw-r--r--pyproject.toml2
4 files changed, 4 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 4a805715..aaeae67a 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,7 +4,7 @@ Changelog
NOTE: isort follows the [semver](https://semver.org/) versioning standard.
Find out more about isort's release policy [here](https://pycqa.github.io/isort/docs/major_releases/release_policy/).
-### 5.8.0 TBD
+### 5.8.0 March 20th 2021
- Fixed #1631: as import comments can in some cases be duplicated.
- Fixed #1667: extra newline added with float-to-top, after skip, in some cases.
- Fixed #1594: incorrect placement of noqa comments with multiple from imports.
diff --git a/isort/_version.py b/isort/_version.py
index 7f4ce2d4..e0b75277 100644
--- a/isort/_version.py
+++ b/isort/_version.py
@@ -1 +1 @@
-__version__ = "5.7.0"
+__version__ = "5.8.0"
diff --git a/isort/settings.py b/isort/settings.py
index c2cd9624..d1fba4c2 100644
--- a/isort/settings.py
+++ b/isort/settings.py
@@ -212,6 +212,7 @@ class _Config:
overwrite_in_place: bool = False
reverse_sort: bool = False
star_first: bool = False
+ import_dependencies = Dict[str, str]
def __post_init__(self):
py_version = self.py_version
diff --git a/pyproject.toml b/pyproject.toml
index 086dadfd..b4813b78 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,7 +3,7 @@ line-length = 100
[tool.poetry]
name = "isort"
-version = "5.7.0"
+version = "5.8.0"
description = "A Python utility / library to sort Python imports."
authors = ["Timothy Crosley <timothy.crosley@gmail.com>"]
license = "MIT"