summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-05-06 07:47:35 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-05-06 07:47:35 -0700
commit5503f0487268127fde31272b8c29329ea2bca15f (patch)
treeaf99c145eaf8bab60b2acd3a1927035866348e09
parent346464fe9539d0d8d928c0b4212ea73a4f92945e (diff)
downloadisort-feature/drop-python34.tar.gz
Drop Python 3.4 support, as it has reached EOLfeature/drop-python34
-rw-r--r--README.rst2
-rwxr-xr-xsetup.py3
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 4 deletions
diff --git a/README.rst b/README.rst
index 9c5a5794..1f644c11 100644
--- a/README.rst
+++ b/README.rst
@@ -31,7 +31,7 @@ isort your python imports for you so you don't have to.
isort is a Python utility / library to sort imports alphabetically, and automatically separated into sections.
It provides a command line utility, Python library and `plugins for various editors <https://github.com/timothycrosley/isort/wiki/isort-Plugins>`_ to quickly sort all your imports.
-It requires Python 3.4+ to run but supports formatting Python 2 code too.
+It requires Python 3.5+ to run but supports formatting Python 2 code too.
.. image:: https://raw.github.com/timothycrosley/isort/develop/example.gif
:alt: Example Usage
diff --git a/setup.py b/setup.py
index d93e3d3b..fb5599fd 100755
--- a/setup.py
+++ b/setup.py
@@ -27,7 +27,7 @@ setup(name='isort',
'requirements': ['pipreqs', 'pip-api'],
'xdg_home': ['appdirs>=1.4.0'],
},
- python_requires=">=3.4",
+ python_requires=">=3.5",
keywords='Refactor, Python, Python3, Refactoring, Imports, Sort, Clean',
classifiers=['Development Status :: 6 - Mature',
'Intended Audience :: Developers',
@@ -36,7 +36,6 @@ setup(name='isort',
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
diff --git a/tox.ini b/tox.ini
index 0b157187..903e9458 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@ envlist =
isort-check,
lint,
mypy,
- py{34,35,36,37,py3}
+ py{35,36,37,py3}
[testenv]
deps =