summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2019-10-12 12:52:06 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2019-10-12 12:52:06 -0700
commit9d27466004f8675f588fedf55e549663addf5602 (patch)
tree16bfae3e175e5c7efdc6c4b71e8bd51878ef77eb
parent205214f034fc7813dfcf49588e8a7497a57d1307 (diff)
downloadisort-feature/add-poetry.tar.gz
Fix tomlkit requirementfeature/add-poetry
-rw-r--r--pyproject.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0240dcd4..9901ca3f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -31,11 +31,12 @@ python = "^3.5"
appdirs = {version = "^1.4.0", optional = true}
pipreqs = {version = "*", optional = true}
requirementslib = {version = "*", optional = true}
+tomlkit = {version = "0.5.3", optional = true}
toml = {version = "*", optional = true}
pip-api = {version = "*", optional = true}
[tool.poetry.extras]
-pipfile = ["pipreqs", "requirementslib"]
+pipfile = ["pipreqs", "tomlkit", "requirementslib"]
pyproject = ["toml"]
requirements = ["pipreqs", "pip-api"]
xdg_home = ["appdirs"]
@@ -57,7 +58,7 @@ appdirs = "^1.4"
pipfile = "^0.0.2"
requirementslib = "^1.5"
pipreqs = "^0.4.9"
-tomlkit = "^0.5.8"
+tomlkit = "0.5.3"
pip_api = "^0.0.12"
[tool.poetry.scripts]