summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstaticdev <staticdev-support@protonmail.com>2022-11-21 18:46:37 +0100
committerstaticdev <staticdev-support@protonmail.com>2022-12-11 15:44:07 +0100
commit193f91bfc652a218ff0198a0eab9ba5359d9a1a1 (patch)
tree02375532f075504c321ae1b8e24e187e822197ff
parent074dbd3b233538cbdc4ec9bb148f108cfcf94dc2 (diff)
downloadisort-ci/release-workflow.tar.gz
Clean poisoned cacheci/release-workflow
-rw-r--r--.github/workflows/tests.yml55
1 files changed, 28 insertions, 27 deletions
diff --git a/.github/workflows/tests.yml b/.github/workflows/tests.yml
index 0108675b..fcf2ce7c 100644
--- a/.github/workflows/tests.yml
+++ b/.github/workflows/tests.yml
@@ -15,35 +15,36 @@ jobs:
- name: Check out the repository
uses: actions/checkout@v3
- - name: Ubuntu cache
- uses: actions/cache@v2
- if: startsWith(matrix.os, 'ubuntu')
- with:
- path: ~/.cache/pip
- key:
- ${{ matrix.os }}-${{ matrix.python }}-${{ hashFiles('**/pyproject.toml') }}
- restore-keys: |
- ${{ matrix.os }}-${{ matrix.python }}-
+ # Clean poisoned cache
+ # - name: Ubuntu cache
+ # uses: actions/cache@v2
+ # if: startsWith(matrix.os, 'ubuntu')
+ # with:
+ # path: ~/.cache/pip
+ # key:
+ # ${{ matrix.os }}-${{ matrix.python }}-${{ hashFiles('**/pyproject.toml') }}
+ # restore-keys: |
+ # ${{ matrix.os }}-${{ matrix.python }}-
- - name: macOS cache
- uses: actions/cache@v2
- if: startsWith(matrix.os, 'macOS')
- with:
- path: ~/Library/Caches/pip
- key:
- ${{ matrix.os }}-${{ matrix.python }}-${{ hashFiles('**/pyproject.toml') }}
- restore-keys: |
- ${{ matrix.os }}-${{ matrix.python }}-
+ # - name: macOS cache
+ # uses: actions/cache@v2
+ # if: startsWith(matrix.os, 'macOS')
+ # with:
+ # path: ~/Library/Caches/pip
+ # key:
+ # ${{ matrix.os }}-${{ matrix.python }}-${{ hashFiles('**/pyproject.toml') }}
+ # restore-keys: |
+ # ${{ matrix.os }}-${{ matrix.python }}-
- - name: Windows cache
- uses: actions/cache@v2
- if: startsWith(matrix.os, 'windows')
- with:
- path: c:\users\runneradmin\appdata\local\pip\cache
- key:
- ${{ matrix.os }}-${{ matrix.python }}-${{ hashFiles('**/pyproject.toml') }}
- restore-keys: |
- ${{ matrix.os }}-${{ matrix.python }}-
+ # - name: Windows cache
+ # uses: actions/cache@v2
+ # if: startsWith(matrix.os, 'windows')
+ # with:
+ # path: c:\users\runneradmin\appdata\local\pip\cache
+ # key:
+ # ${{ matrix.os }}-${{ matrix.python }}-${{ hashFiles('**/pyproject.toml') }}
+ # restore-keys: |
+ # ${{ matrix.os }}-${{ matrix.python }}-
- name: Set up Python ${{ matrix.python }}
uses: actions/setup-python@v4