summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py70
1 files changed, 34 insertions, 36 deletions
diff --git a/setup.py b/setup.py
index ba6627c..d5a3427 100644
--- a/setup.py
+++ b/setup.py
@@ -4,41 +4,39 @@ from setuptools import setup
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ with open(os.path.join(os.path.dirname(__file__), *rnames)) as read_file:
+ return read_file.read()
-setup(name='isodate',
- version='0.7.0.dev0',
- packages=['isodate', 'isodate.tests'],
- package_dir={'': 'src'},
-
- # PyPI metadata
- author='Gerhard Weis',
- author_email='gerhard.weis@proclos.com',
- description='An ISO 8601 date/time/duration parser and formatter',
- license='BSD-3-Clause',
- license_files = ('LICENSE',),
- # keywords = '',
- url='https://github.com/gweis/isodate/',
-
- long_description=(read('README.rst') +
- read('CHANGES.txt') +
- read('TODO.txt')),
-
- classifiers=['Development Status :: 4 - Beta',
- # 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Topic :: Internet',
- ('Topic :: Software Development :'
- ': Libraries :: Python Modules'),
- ],
- test_suite='isodate.tests.test_suite')
+setup(
+ name="isodate",
+ version="0.7.0.dev0",
+ packages=["isodate", "isodate.tests"],
+ package_dir={"": "src"},
+ # PyPI metadata
+ author="Gerhard Weis",
+ author_email="gerhard.weis@proclos.com",
+ description="An ISO 8601 date/time/duration parser and formatter",
+ license="BSD-3-Clause",
+ license_files=("LICENSE",),
+ # keywords = '',
+ url="https://github.com/gweis/isodate/",
+ long_description=(read("README.rst") + read("CHANGES.txt") + read("TODO.txt")),
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ # 'Environment :: Web Environment',
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Internet",
+ ("Topic :: Software Development :" ": Libraries :: Python Modules"),
+ ],
+ test_suite="isodate.tests.test_suite",
+)