summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-04-22 22:40:52 +0300
committerHugo van Kemenade <hugovk@users.noreply.github.com>2021-09-13 11:54:57 +0300
commit6923aee503ac81c26d2425592e90a2254c7666d9 (patch)
treeca5ffeff7069564f9fa0ac52b14e16c48188430e /tox.ini
parent27cebc56a0f6a900eeb897512879d545095f410b (diff)
downloadisodate-6923aee503ac81c26d2425592e90a2254c7666d9.tar.gz
Move from Travis CI to GitHub Actions and Coveralls to Codecov
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini21
1 files changed, 10 insertions, 11 deletions
diff --git a/tox.ini b/tox.ini
index 16616ab..cd25d99 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,20 +1,19 @@
[tox]
-envlist = py27,py34,py35,py36,pypy,pypy3,flake,cover
+envlist =
+ lint
+ py{36, 37, 38, 39, py3}
[testenv]
deps =
commands =
{envpython} setup.py test
-
-[testenv:flake]
-basepython = python3.5
-commands=
- pip install --quiet flake8
- {envpython} setup.py clean --all flake8
-
-[testenv:cover]
-basepython = python3.5
-commands =
pip install --quiet coverage
{envpython} setup.py clean --all
coverage run setup.py test
+ coverage xml
+
+[testenv:lint]
+deps = pre-commit
+commands = pre-commit run --all-files
+skip_install = true
+passenv = PRE_COMMIT_COLOR