summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGerhard Weis <gerhard.weis@gmx.com>2012-01-06 13:24:37 +1000
committerGerhard Weis <gerhard.weis@gmx.com>2012-01-06 13:24:37 +1000
commitaea721becd4bbd844329a62a26035837e973eb15 (patch)
tree46b40babe21d0dd9de6c0a4ee9941541aa5db170 /setup.py
parent3b9accc1413f4bdd6233b3d01ebf057342ac6306 (diff)
downloadisodate-aea721becd4bbd844329a62a26035837e973eb15.tar.gz
* support Python 3
* moved tests package into isolate package
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 13 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index f565c3b..21e5418 100644
--- a/setup.py
+++ b/setup.py
@@ -30,17 +30,25 @@ import os
setupargs = {}
try:
+ from distutils.command.build_py import build_py_2to3 as build_py
+except ImportError:
+ # 2.x
+ from distutils.command.build_py import build_py
+
+try:
from setuptools import setup
- setupargs['test_suite'] = 'tests.test_suite'
+ setupargs['test_suite'] = 'isodate.tests.test_suite'
+ setupargs['use_2to3'] = True
except ImportError:
from distutils.core import setup
+ setupargs['cmdclass'] = {'build_py': build_py}
def read(*rnames):
return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
setup(name='isodate',
- version='0.4.5',
- packages=['isodate',],
+ version='0.4.6',
+ packages=['isodate', 'isodate.tests'],
package_dir={'': 'src'},
# dependencies:
@@ -64,6 +72,8 @@ setup(name='isodate',
'License :: OSI Approved :: BSD License',
'Operating System :: OS Independent',
'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
'Topic :: Internet',
'Topic :: Software Development :: Libraries :: Python Modules',
],